Bug 981018 - rubygems missing?
rubygems missing?
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: yum (Show other bugs)
el6
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jeff Sheltren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 15:26 EDT by jason.prokopowich
Modified: 2013-07-30 09:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-30 09:58:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jason.prokopowich 2013-07-03 15:26:49 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.yum install rubygem-passenger
2.
3.

Actual results:
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package rubygem-passenger.x86_64 0:3.0.17-2.el6.1 will be installed
--> Processing Dependency: ruby(abi) = 1.8 for package: rubygem-passenger-3.0.17-2.el6.1.x86_64
--> Processing Dependency: rubygem(fastthread) >= 1.0.1 for package: rubygem-passenger-3.0.17-2.el6.1.x86_64
--> Processing Dependency: rubygems for package: rubygem-passenger-3.0.17-2.el6.1.x86_64
--> Processing Dependency: rubygem(rake) for package: rubygem-passenger-3.0.17-2.el6.1.x86_64
--> Processing Dependency: rubygem(rack) for package: rubygem-passenger-3.0.17-2.el6.1.x86_64
--> Running transaction check
---> Package ruby-libs.x86_64 0:1.8.7.352-10.el6_4 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.352-10.el6_4.x86_64
---> Package rubygem-fastthread.x86_64 0:1.0.7-2.el6 will be installed
--> Processing Dependency: rubygems for package: rubygem-fastthread-1.0.7-2.el6.x86_64
---> Package rubygem-passenger.x86_64 0:3.0.17-2.el6.1 will be installed
--> Processing Dependency: rubygems for package: rubygem-passenger-3.0.17-2.el6.1.x86_64
--> Processing Dependency: rubygem(rake) for package: rubygem-passenger-3.0.17-2.el6.1.x86_64
---> Package rubygem-rack.noarch 1:1.1.0-2.el6 will be installed
--> Processing Dependency: rubygems for package: 1:rubygem-rack-1.1.0-2.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: 1:rubygem-rack-1.1.0-2.el6.noarch
--> Running transaction check
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package ruby.x86_64 0:1.8.7.352-10.el6_4 will be installed
---> Package rubygem-fastthread.x86_64 0:1.0.7-2.el6 will be installed
--> Processing Dependency: rubygems for package: rubygem-fastthread-1.0.7-2.el6.x86_64
---> Package rubygem-passenger.x86_64 0:3.0.17-2.el6.1 will be installed
--> Processing Dependency: rubygems for package: rubygem-passenger-3.0.17-2.el6.1.x86_64
--> Processing Dependency: rubygem(rake) for package: rubygem-passenger-3.0.17-2.el6.1.x86_64
---> Package rubygem-rack.noarch 1:1.1.0-2.el6 will be installed
--> Processing Dependency: rubygems for package: 1:rubygem-rack-1.1.0-2.el6.noarch
--> Finished Dependency Resolution
Error: Package: rubygem-fastthread-1.0.7-2.el6.x86_64 (epel)
           Requires: rubygems
Error: Package: 1:rubygem-rack-1.1.0-2.el6.noarch (epel)
           Requires: rubygems
Error: Package: rubygem-passenger-3.0.17-2.el6.1.x86_64 (epel)
           Requires: rubygems
Error: Package: rubygem-passenger-3.0.17-2.el6.1.x86_64 (epel)
           Requires: rubygem(rake)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Dependencies installed and package installed.

Additional info:
Comment 1 Jeff Sheltren 2013-07-25 14:45:37 EDT
I can successfully resolve dependencies for this package on a CentOS 6 box.  However, I see that there's a newer version of rubygem-passenger than you show in your output -- 3.0.21-3.el6.

At any rate, this really isn't a yum bug.  If you continue having problems, I suggest we move this over to rubygems / rubygem-passenger.
Comment 2 jason.prokopowich 2013-07-26 13:56:00 EDT
(In reply to Jeff Sheltren from comment #1)
> I can successfully resolve dependencies for this package on a CentOS 6 box. 
> However, I see that there's a newer version of rubygem-passenger than you
> show in your output -- 3.0.21-3.el6.
> 
> At any rate, this really isn't a yum bug.  If you continue having problems,
> I suggest we move this over to rubygems / rubygem-passenger.

Please provide the "rubygems" link from within the EPEL site. From what I can see it doesn't exist.
Comment 3 Jeff Sheltren 2013-07-29 10:54:41 EDT
rubygems is not in EPEL, it's in base.  Or if you're using RHEL, it may be in some additional repo, I'm not sure.  What does 'yum list rubygems' show?
Comment 4 jason.prokopowich 2013-07-30 09:37:07 EDT
(In reply to Jeff Sheltren from comment #3)
> rubygems is not in EPEL, it's in base.  Or if you're using RHEL, it may be
> in some additional repo, I'm not sure.  What does 'yum list rubygems' show?

rubygems is not available for RHEL6 from RedHat (I searched the RHN).

rubygems is available for RHEL5 via the epel.

rubygems is available for Centos6 via Centos6 base.

Who does this have to go to get rubygems added to the EPEL6 x64?
Comment 5 Jeff Sheltren 2013-07-30 09:58:36 EDT
I'm told rubygems may be in the 'optional' channel.  It won't be included in EPEL since it's already included in RHEL.

Note You need to log in before you can comment on or make changes to this bug.