Bug 981034 - unable to add RHS-2.1-20130630.n.0-RHS-x86_64-DVD1.iso to rhsc-bb5
unable to add RHS-2.1-20130630.n.0-RHS-x86_64-DVD1.iso to rhsc-bb5
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Sahina Bose
Dustin Tsang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 16:18 EDT by Dustin Tsang
Modified: 2015-07-13 00:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: bb6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (110.08 KB, text/plain)
2013-07-03 16:18 EDT, Dustin Tsang
no flags Details

  None (edit)
Description Dustin Tsang 2013-07-03 16:18:10 EDT
Created attachment 768443 [details]
engine log

Description of problem:

unable to add RHS-2.1-20130630.n.0-RHS-x86_64-DVD1.iso to rhsc-bb5

Stage: Termination¬
2013-07-03 16:12:44,500 ERROR [org.ovirt.engine.core.utils.ssh.SSHDialog] (pool-4-thread-50) SSH error running command root@rhsc-bb5-node-a:'umask 0077; MYTMP="$(mktemp -t ovirt-XXXXXXXXXX)"; trap "chmod -R u+rwX \"${MYTMP}\" > /dev/null 2>&1; rm -fr \"${MYTMP}\" > /dev/null 2>&1" 0; rm -fr "${MYTMP}" && mkdir "${MYTMP}" && tar -C "${MYTMP}" -x &&  "${MYTMP}"/setup DIALOG/dialect=str:machine DIALOG/customization=bool:True': java.io.IOException: Command returned failure code 1 during SSH session 'root@rhsc-bb5-node-a'¬


Version-Release number of selected component (if applicable):

rhsc-bb5
RHS-2.1-20130630.n.0-RHS-x86_64-DVD1.iso

How reproducible:


Steps to Reproduce:
1.create a 3.2 cluster
2. add RHS-2.1-20130630.n.0-RHS-x86_64-DVD1.iso to cluster


Actual results:

failed to add
event shows: " installation failed. Command returned failure code 1 during SSH session 'root@rhsc-bb5-node-a'."

Expected results:
node adds successfully

Additional info:
Comment 2 Sahina Bose 2013-07-31 01:48:07 EDT
From engine logs, it looks like an issue with executing the tar command - this issue has been fixed in subsequent builds.
Without the host-deploy log, cannot identify exact error.
Please check with new build.
Comment 3 Dustin Tsang 2013-08-01 09:33:04 EDT
verified in bb6
Comment 4 Scott Haines 2013-09-23 18:25:51 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.