Bug 981039 - [abrt] liveusb-creator-3.11.8-1.fc18: gui.py:80:__init__:LiveUSBError: Unknown release: Fedora Desktop x86_64 19 1
[abrt] liveusb-creator-3.11.8-1.fc18: gui.py:80:__init__:LiveUSBError: Unknow...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
abrt_hash:5e77c09735116b1a3dfa47cf54c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 16:38 EDT by Awk
Modified: 2016-09-19 22:45 EDT (History)
7 users (show)

See Also:
Fixed In Version: liveusb-creator-3.12.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:10:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (887 bytes, text/plain)
2013-07-03 16:38 EDT, Awk
no flags Details
File: core_backtrace (208 bytes, text/plain)
2013-07-03 16:38 EDT, Awk
no flags Details
File: environ (272 bytes, text/plain)
2013-07-03 16:38 EDT, Awk
no flags Details

  None (edit)
Description Awk 2013-07-03 16:38:43 EDT
Description of problem:
simple ran liveusb-creator
selected Fedora Desktop19 1
selected my usb stick
clicked create

---- got this error report ----

Version-Release number of selected component:
liveusb-creator-3.11.8-1.fc18

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python -tt /usr/sbin/liveusb-creator
executable:     /usr/sbin/liveusb-creator
kernel:         3.9.6-200.fc18.x86_64
runlevel:       N 3
uid:            0

Truncated backtrace:
gui.py:80:__init__:LiveUSBError: Unknown release: Fedora Desktop x86_64 19 1

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 569, in begin
    proxies=self.live.get_proxies())
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 80, in __init__
    raise LiveUSBError(_("Unknown release: %s" % release))
LiveUSBError: Unknown release: Fedora Desktop x86_64 19 1

Local variables in innermost frame:
release: PyQt4.QtCore.QString(u'Fedora Desktop x86_64 19 1')
progress: <liveusb.gui.DownloadProgress object at 0xbcd290>
self: <liveusb.gui.ReleaseDownloader object at 0xbcd7a0>
proxies: {}
rel: {'url': 'https://alt.fedoraproject.org/pub/alt/spins/linux/releases/16/Spins/i686/Fedora-16-i686-Live-SoaS.iso', 'sha256': '5aa938737cc4ebeb1d269c4d8b2bf56e41bacd1967c3997b8969b42b88b63bfa', 'name': 'Sugar on a Stick v6 Pineapple'}
Comment 1 Awk 2013-07-03 16:38:46 EDT
Created attachment 768459 [details]
File: backtrace
Comment 2 Awk 2013-07-03 16:38:49 EDT
Created attachment 768460 [details]
File: core_backtrace
Comment 3 Awk 2013-07-03 16:38:52 EDT
Created attachment 768461 [details]
File: environ
Comment 4 MartinG 2013-07-08 14:39:49 EDT
I can confirm similar error (on F18, 64 bit):

# rpm -q liveusb-creator 
liveusb-creator-3.11.8-1.fc18.noarch
thira:~:# liveusb-creator 
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 569, in begin
    proxies=self.live.get_proxies())
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 80, in __init__
    raise LiveUSBError(_("Unknown release: %s" % release))
liveusb.creator.LiveUSBError: Unknown release: Fedora KDE x86_64 19 1
Comment 5 Martin Kolman 2013-10-10 10:49:28 EDT
Also getting this (the same error) on Fedora 19, 64 bit.

How to reproduce:
1) start liveusb-creator:
sudo liveusb-creator

2) refresh the distro list as there is no F19 in the list on startup

3) select "Fedora Desktop x86_64"

4) select some usb target device

5) press "Create Live Usb"

Any you get the same old:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 569, in begin
    proxies=self.live.get_proxies())
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 80, in __init__
    raise LiveUSBError(_("Unknown release: %s" % release))
liveusb.creator.LiveUSBError: Unknown release: Fedora Desktop x86_64 19 1
Comment 6 Martin Kolman 2013-10-10 11:02:39 EDT
It looks like this issue has been fixed in upstream, according to this Github issue:
https://github.com/lmacken/liveusb-creator/issues/5

I've tried liveusb-creator from upstream Git and it indeed doesn't exhibit the bug.
Comment 7 Fedora Update System 2013-10-17 18:58:26 EDT
liveusb-creator-3.12.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/liveusb-creator-3.12.0-1.fc19
Comment 8 Fedora Update System 2013-10-17 18:59:24 EDT
liveusb-creator-3.12.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/liveusb-creator-3.12.0-1.fc18
Comment 9 Fedora Update System 2013-10-17 19:00:14 EDT
liveusb-creator-3.12.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/liveusb-creator-3.12.0-1.fc20
Comment 11 Ivan Romanov 2013-10-18 01:44:53 EDT
Please don't forget to put sources tarball to https://fedorahosted.org/releases/l/i/liveusb-creator/. I build own version of liveusb-creator for Russian Fedora project. So it is important for me and for users.
Comment 12 Luke Macken 2013-10-18 02:18:31 EDT
(In reply to Ivan Romanov from comment #11)
> Please don't forget to put sources tarball to
> https://fedorahosted.org/releases/l/i/liveusb-creator/. I build own version
> of liveusb-creator for Russian Fedora project. So it is important for me and
> for users.

Uploaded. Thanks!
Comment 13 Fedora Update System 2013-10-18 20:09:50 EDT
Package liveusb-creator-3.12.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liveusb-creator-3.12.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19384/liveusb-creator-3.12.0-1.fc20
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-11-10 02:10:41 EST
liveusb-creator-3.12.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-12-11 21:56:08 EST
liveusb-creator-3.12.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-12-11 21:57:28 EST
liveusb-creator-3.12.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.