Bug 981101 - Throw an exception "Unknown network interface: 'bond0'" when selecting a bond to configure.
Throw an exception "Unknown network interface: 'bond0'" when selecting a bond...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 23:00 EDT by haiyang,dong
Modified: 2014-01-21 14:43 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
After creating a bond using "Create Bond", for example bond0, moving to the network page and selecting the bond for configuration, the system would generate the following exception: "Unknown network interface: 'bond0'" This was caused because previously Node could not discover all the allowed network layouts. This is now fixed, so 'bond' can be created, selected, and configured.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:43:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for execption for bond.png (3.78 KB, image/png)
2013-07-03 23:00 EDT, haiyang,dong
no flags Details
attached Screenshot (45.62 KB, image/png)
2013-08-02 04:05 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16505 None None None Never

  None (edit)
Description haiyang,dong 2013-07-03 23:00:41 EDT
Created attachment 768579 [details]
attached Screenshot for execption for bond.png

Description of problem:
Enter into network page and clicking "Create Bond" button to create a bond with named "bond0".
After create this bond successfully, then enter into network page to select "bond0" to configure it, but 
when selecting this bond, it will throw an exception "Unknown network interface: 'bond0'"(Seen execption for bond.png)


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1710.el6
ovirt-node-3.0.0-1.999.20130702120359git0015156.el6.noarch

How reproducible:
100%
 
Steps to Reproduce:
1.Enter into network page and clicking "Create Bond" button to create a bond with named "bond0".
2.After create this bond successfully, then enter into network page to select "bond0" to configure it

Actual result:
After step 2,when selecting this bond, it will throw an exception "Unknown network interface: 'bond0'".

Expect result:
Configure "bond0" successfully.

Additional info:
Comment 2 Fabian Deutsch 2013-07-05 10:29:47 EDT
I guess this is fixed with http://gerrit.ovirt.org/16505

At least it is not reproducable with the latest master.
Comment 4 haiyang,dong 2013-08-02 04:05:38 EDT
Created attachment 781876 [details]
attached Screenshot

Test version:
rhev-hypervisor6-6.5-20130725.0.el6 
ovirt-node-3.0.0-6.1.el6

Tested as follows:
.Enter into network page and clicking "Create Bond" button to create a bond with named "bond0".
2.After create this bond successfully, then enter into network page.

After step2, check that there was no "bond0" in available system nics list.
so this bug didn't fix, need re-assigned this bug.
Comment 6 Fabian Deutsch 2013-12-10 10:37:38 EST
Haiyang,

does this still exist in the latest RHEV-H base image build?
Comment 7 haiyang,dong 2013-12-10 21:29:14 EST
Test version:
rhevh-6.5-20131031.1.0.iso
ovirt-node-3.0.1-7.el6

Tested as follows:
1.Enter into network page and clicking "Create Bond" button to create a bond with named "bond0".
2.After create this bond successfully, then enter into network page to select "bond0" to configure it up with ipv4 setting.

no exception was thrown during above steps, so this bug has been fixed on rhevh-6.5-20131031.1.0.iso, after the status of this bug changed "ON_QA", i'll verify this bug.
Comment 8 Cheryn Tan 2014-01-08 00:37:06 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 9 haiyang,dong 2014-01-13 04:22:12 EST
Test version:
ovirt-node-3.0.1-16.el6_5.noarch.rpm
rhevh-6.5-20140110.1

Tested as follows:
1.Enter into network page and clicking "Create Bond" button to create a bond with named "bond0".
2.After create this bond successfully, then enter into network page to select "bond0" to configure it up with ipv4 setting.

no exception was thrown during above steps, so this bug has been fixed on rrhevh-6.5-20140110.1,change the status into "verified"
Comment 11 errata-xmlrpc 2014-01-21 14:43:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.