Bug 981169 - Configure nic with "vlan" failed .
Configure nic with "vlan" failed .
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 03:38 EDT by haiyang,dong
Modified: 2014-01-21 14:44 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.0-6.el6
Doc Type: Bug Fix
Doc Text:
Previously Node conuldn't discover all allowed network layouts. This is now fixed and additionally many unit tests were added to prevent regressions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:44:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for ifconfig (60.75 KB, image/png)
2013-07-04 03:38 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16505 None None None Never
Red Hat Product Errata RHBA-2014:0033 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-21 19:14:30 EST

  None (edit)
Description haiyang,dong 2013-07-04 03:38:38 EDT
Created attachment 768619 [details]
attached Screenshot for ifconfig

Description of problem:
Enter into network page and select a nic "eth0" to configure it with "DHCP" of ipv4 setting and vlan id "20".
Then clicking "Save" button to apply the setting, although it Pop-up indication "All changes were applied successfully" 
but actually it didn't success to configure nic with "vlan"
execute "ifconfig" couldn't find this nic info(seen ifconfig.png) 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1710.el6
ovirt-node-3.0.0-1.999.20130702120359git0015156.el6.noarch

How reproducible:
100%
 
Steps to Reproduce:


Actual result:
After step 2, although it Pop-up indication "All changes were applied successfully" 
but actually it didn't success to configure nic with "vlan"

Expect result:
Configure nic with "vlan" success

Additional info:
Comment 2 Fabian Deutsch 2013-07-05 10:39:15 EDT
This bug has been fixed with the (see above) gerrit change.

Tested as follows (with patch):
1. Enter NIC details dialog
2. Configure a NIC with static IP and vlan 42
3. Save
4. Drop to shell and check with ip l and ipa that a vlan device exists and the ipaddr is assigned to it

There is a unittest covering this szenario
Comment 4 haiyang,dong 2013-08-02 03:16:35 EDT
Need add Keywords "Regression" into this bug for it's a regression bug from rhev-h 6.4.z to rhev-h 6.5
Comment 6 haiyang,dong 2013-10-22 06:05:02 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

Tested as follows :
1. Enter NIC details dialog
2. Configure a NIC with dhcp IPv4 and vlan 20
3. Save
4. Drop to shell and check with ip l and ipa that a vlan device exists and the ipaddr is assigned to it

But met another issue about "Shown incorrect info for the item "VLAN ID" after configured nic with "vlan", cshao has reported another bug 1020792 to track it.

so change the status into "VERIFIED".
Comment 8 Cheryn Tan 2013-11-07 19:26:36 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 14:44:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.