Bug 981238 - Occurrence error when access "https://broker_domain/broker"
Occurrence error when access "https://broker_domain/broker"
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master (Show other bugs)
1.2.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 05:57 EDT by jzu
Modified: 2013-11-03 20:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 09:04:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jzu 2013-07-04 05:57:24 EDT
Description of problem:
When I accessed the address of "https://broker_domain/broker" from a browser,
will meet errors like "Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request." in the browser,
and "Exception ActionController::RoutingError in application (No route matches [GET] "/") (process 3575, thread #<Thread:0x00000001e5e100>):
	from /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
	from /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
	from /opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/rack/logger.rb:26:in `call_app'
	from /opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/rack/logger.rb:16:in `call'
	from /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/request_id.rb:22:in `call'
	from /opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/methodoverride.rb:21:in `call'
" in the logger of "/var/log/openshift/broker/httpd/error_log "


Version-Release number of selected component (if applicable):
OpenShiftEnterprise/1.2/2013-07-01.1/


How reproducible:
always

Steps to Reproduce:
1. accessed the address of "https://broker_domain/broker" from a browser
2. tailf /var/log/openshift/broker/httpd/error_log 


Actual results:
the respone message is "Internal Server Error"



Expected results:
the respone message is below
Not Found

The requested URL /brokers was not found on this server.


Additional info:
Comment 2 Brenton Leanhardt 2013-08-15 10:56:12 EDT
This is by design.  Do you know of anything that accesses this path?
Comment 3 jzu 2013-08-16 04:57:44 EDT
I agree with you, this is an useless path by design. But maybe someone access it and the browser display error information, which is inappropriate.
Comment 4 Brenton Leanhardt 2013-08-16 09:04:50 EDT
Only the web console is designed to be accessed by a Browser.  The Broker is just the REST API.  Unless you find somewhere in the OpenShift documentation that directs users to access the REST API with a browser we'll close this.

Note You need to log in before you can comment on or make changes to this bug.