Bug 981249 - ruby193-rubygem-open4 should be installed as dependency of cartridge package.
ruby193-rubygem-open4 should be installed as dependency of cartridge package.
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 06:10 EDT by Johnny Liu
Modified: 2017-03-08 12 EST (History)
3 users (show)

See Also:
Fixed In Version: rubygem-openshift-origin-node-1.9.14-1.2
Doc Type: Bug Fix
Doc Text:
A missing dependency in the RPM spec file for the rubygem-openshift-origin-node package caused installation errors for OpenShift Enterprise cartridges. With this fix, the dependencies are updated so that the ruby193-rubygem-open4 package is installed with rubygem-openshift-origin-node, and the errors no longer occur.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:18:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1138 normal SHIPPED_LIVE OpenShift Enterprise 1.2.1 bug fix and enhancement update 2013-08-05 17:14:54 EDT

  None (edit)
Description Johnny Liu 2013-07-04 06:10:23 EDT
Description of problem:
When ruby193-rubygem-open4 is not installed on your system, yum install cartridge will throw out exception.

Version-Release number of selected component (if applicable):
http://download.lab.bos.redhat.com/rel-eng/OpenShiftEnterprise/1.2/2013-07-02.1/JBoss_EAP6_Cartridge/x86_64/

How reproducible:
Always

Steps to Reproduce:
1.Make sure your system does not install ruby193-rubygem-open4.
2.yum install openshift-origin-cartridge-jbosseap
3.

Actual results:
# yum install openshift-origin-cartridge-jbosseap
<--snip-->
  Installing : openshift-origin-cartridge-jbosseap-2.3.10-1.1.el6op.noarch                                                                                                           4/4 
Non-fatal POSTIN scriptlet failure in rpm package openshift-origin-cartridge-jbosseap-2.3.10-1.1.el6op.noarch
/opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require': cannot load such file -- open4 (LoadError)
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.9.13/lib/openshift-origin-node/utils/shell_exec.rb:19:in `<top (required)>'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:60:in `require'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:60:in `rescue in require'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:35:in `require'
	from /usr/sbin/oo-admin-cartridge:22:in `<main>'
warning: %post(openshift-origin-cartridge-jbosseap-2.3.10-1.1.el6op.noarch) scriptlet failed, exit status 1
<--snip-->

Expected results:
installation should not throw any exception.

Additional info:
Comment 1 Johnny Liu 2013-07-04 06:13:12 EDT
Except ruby-1.8 and ruby-1.9 cartridge, this issue also happened with all the other cartridges.
Comment 3 Brenton Leanhardt 2013-07-05 09:35:04 EDT
Looks like the spec for rubygem-openshift-origin-node only has:

# non-scl open4 required for oo-cgroup-read bug 924556 until selinux fix for bug 912215 is available
Requires:      rubygem(open4)

It needs a requirement on the SCL open4 package too.
Comment 4 openshift-github-bot 2013-07-08 10:30:53 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/fccc36adfd7caa709345e9acb457a87124872363
Bug 981249 - rubygem-openshift-origin-node was missing open4 dependency
Comment 6 Johnny Liu 2013-07-17 01:45:48 EDT
Verified this bug with 1.2/2013-07-16.1, and PASS.

When installing openshift cartridges, both ruby193-rubygem-open4 and rubygem-open4 will be installed as dependency.
Comment 9 errata-xmlrpc 2013-08-05 13:18:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.