Bug 981281 - [abrt] python-ipython-console-0.13.2-1.fc18: importstring.py:40:import_item:ImportError: No module named html.notebook.notebookapp
[abrt] python-ipython-console-0.13.2-1.fc18: importstring.py:40:import_item:I...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ipython (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
abrt_hash:fbc99e688d6fa417141598b5fb3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 07:15 EDT by alain.thiaville
Modified: 2014-05-03 19:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-04 11:10:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.17 KB, text/plain)
2013-07-04 07:15 EDT, alain.thiaville
no flags Details
File: core_backtrace (1.60 KB, text/plain)
2013-07-04 07:15 EDT, alain.thiaville
no flags Details
File: environ (3.60 KB, text/plain)
2013-07-04 07:15 EDT, alain.thiaville
no flags Details

  None (edit)
Description alain.thiaville 2013-07-04 07:15:41 EDT
Version-Release number of selected component:
python-ipython-console-0.13.2-1.fc18

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/ipython help notebook
executable:     /usr/bin/ipython
kernel:         3.9.6-200.fc18.x86_64
runlevel:       N 5
uid:            1001

Truncated backtrace:
importstring.py:40:import_item:ImportError: No module named html.notebook.notebookapp

Traceback (most recent call last):
  File "/usr/bin/ipython", line 7, in <module>
    launch_new_instance()
  File "/usr/lib/python2.7/site-packages/IPython/frontend/terminal/ipapp.py", line 388, in launch_new_instance
    app.initialize()
  File "<string>", line 2, in initialize
  File "/usr/lib/python2.7/site-packages/IPython/config/application.py", line 84, in catch_config_error
    return method(app, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/IPython/frontend/terminal/ipapp.py", line 313, in initialize
    super(TerminalIPythonApp, self).initialize(argv)
  File "<string>", line 2, in initialize
  File "/usr/lib/python2.7/site-packages/IPython/config/application.py", line 84, in catch_config_error
    return method(app, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/IPython/core/application.py", line 325, in initialize
    self.parse_command_line(argv)
  File "/usr/lib/python2.7/site-packages/IPython/frontend/terminal/ipapp.py", line 308, in parse_command_line
    return super(TerminalIPythonApp, self).parse_command_line(argv)
  File "<string>", line 2, in parse_command_line
  File "/usr/lib/python2.7/site-packages/IPython/config/application.py", line 84, in catch_config_error
    return method(app, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/IPython/config/application.py", line 420, in parse_command_line
    return self.initialize_subcommand(subc, subargv)
  File "<string>", line 2, in initialize_subcommand
  File "/usr/lib/python2.7/site-packages/IPython/config/application.py", line 84, in catch_config_error
    return method(app, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/IPython/config/application.py", line 352, in initialize_subcommand
    subapp = import_item(subapp)
  File "/usr/lib/python2.7/site-packages/IPython/utils/importstring.py", line 40, in import_item
    module = __import__(package,fromlist=[obj])
ImportError: No module named html.notebook.notebookapp

Local variables in innermost frame:
obj: 'NotebookApp'
name: 'IPython.frontend.html.notebook.notebookapp.NotebookApp'
package: 'IPython.frontend.html.notebook.notebookapp'
Comment 1 alain.thiaville 2013-07-04 07:15:45 EDT
Created attachment 768730 [details]
File: backtrace
Comment 2 alain.thiaville 2013-07-04 07:15:48 EDT
Created attachment 768731 [details]
File: core_backtrace
Comment 3 alain.thiaville 2013-07-04 07:15:51 EDT
Created attachment 768732 [details]
File: environ
Comment 4 Thomas Spura 2013-07-04 07:43:24 EDT
The notebook can be found in the package python-ipython-notebook.

Could you please install that package and try it again?
Comment 5 alain.thiaville 2013-07-04 08:56:28 EDT
all rpm python-ipython already installed i.e 'rpm -qa \*[iI]python\*' reports
python-ipython-0.13.2-1.fc18.noarch
python-ipython-gui-0.13.2-1.fc18.noarch
python-ipython-console-0.13.2-1.fc18.noarch
python-ipython-notebook-0.13.2-1.fc18.noarch
python-ipython-doc-0.13.2-1.fc18.noarch
python-ipython-tests-0.13.2-1.fc18.noarch
and no other available as reported by "yum list available python-[iI]python\*":

Modules complémentaires chargés : aliases, auto-update-debuginfo, changelog, fastestmirror, filter-data, fs-snapshot, keys, langpacks, list-data, merge-conf, post-
                                : transaction-actions, presto, priorities, protectbase, ps, puppetverify, refresh-packagekit, refresh-updatesd, remove-with-leaves, rpm-
                                : warm-cache, security, show-leaves, tmprepo, tsflags, upgrade-helper, verify, versionlock
Loading mirror speeds from cached hostfile
 * fedora: fr2.rpmfind.net
 * rpmfusion-free: fr2.rpmfind.net
 * rpmfusion-free-updates: fr2.rpmfind.net
 * rpmfusion-nonfree: fr2.rpmfind.net
 * rpmfusion-nonfree-updates: fr2.rpmfind.net
 * updates: fr2.rpmfind.net
Skipping filters plugin, no data
0 packages excluded due to repository protections
Erreur : Aucun paquet correspondant à lister
Comment 6 alain.thiaville 2013-07-04 11:10:14 EDT
you can CLOSE the problem. It has been resolved with "sudo yum reinstall   ipython-python-notebook-0.13.2-1.fc18.noarch".
Nothing signaled in /var/log/yum.log but I noticed with rpm -ql ipython-python-notebook" and ls that /usr/lib/python2.7/site-packages/IPython/frontend/html/__init__.py  was missing !!! ... so i reinstalled the package

Note You need to log in before you can comment on or make changes to this bug.