Bug 981294 - horizon: unclear error when failing to create a volume
horizon: unclear error when failing to create a volume
Status: CLOSED DUPLICATE of bug 983147
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: 4.0
Assigned To: Julie Pichon
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 08:16 EDT by Dafna Ron
Modified: 2015-06-04 17:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 07:55:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (4.90 MB, application/x-gzip)
2013-07-17 05:05 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2013-07-04 08:16:44 EDT
Description of problem:

I tried creating a volume and selected "None" in "Use snapshot as a source" scroll. 
when I press OK we get an alert in the UI "unable to create volume" 

since there are so many logs in openstack and searching which log we should look at + we have no UUID yet or a command printed in the logs a user will find it hard to debug. 
hence, a clear error on what is missing will be a huge help in situation like this. 

Version-Release number of selected component (if applicable):

python-django-horizon-2013.1.2-1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. open the new volume dialogue
2. select None in "use snapshot as source" scroll 
3. press OK

Actual results:

dialogue shows an error "unable to create volume" 

Expected results:

since debugging this issue is difficult I think that a UI need to show a more informative errors

Additional info:
Comment 1 Julie Pichon 2013-07-16 12:13:18 EDT
Could you provide more information on what was actually the problem here? There's definitely a lot of work to be done to improve error messages, if we could fix this one that would be good. Normally we try to surface to the UI the error message sent back by the APIs (cinder in this case).

I can't reproduce the problem using a nameless snapshot ("None"). What's the stack trace in the horizon error logs? Is there something special about the source snapshot?
Comment 2 Dafna Ron 2013-07-17 05:00:26 EDT
(In reply to Julie Pichon from comment #1)
> Could you provide more information on what was actually the problem here?
> There's definitely a lot of work to be done to improve error messages, if we
> could fix this one that would be good. Normally we try to surface to the UI
> the error message sent back by the APIs (cinder in this case).
> 
> I can't reproduce the problem using a nameless snapshot ("None"). What's the
> stack trace in the horizon error logs? Is there something special about the
> source snapshot?

In this case I cannot create a a volume because I am using a snapshot which was created with ERROR. 
you can reproduce this with external nfs storage in which snapshots for volumes are not yet supported. 
create a volume -> create a snapshot (which will be created with status ERROR) -> create a second volume from the Error snapshot. 

I could not find any errors in the log except for the create snapshot error (which also has no alert in horizon) 

horizon log shows nothing at all but I will attach nova,cinder and horizon logs from this specific scenario.
Comment 3 Dafna Ron 2013-07-17 05:05:35 EDT
Created attachment 774692 [details]
logs

I echoed >>>>BUG981294>>>>> into the logs so you can see the start point for the create volume from error snapshot
Comment 4 Julie Pichon 2013-07-17 07:55:59 EDT
Thank you for the additional information. By default, because the create call is asynchronous Horizon cannot show an alert (see comment 3 on bug 976279 for more information), only that the status is in Error.

In this particular case, since it's related to the error condition in bug 983147, I'm going to mark this one as a duplicate. When bug 983147 is fixed, this will resolve this bug as well.

(Note, it's possible to adjust Horizon's logging configuration, in /etc/openstack-dashboard/local_settings.py)

*** This bug has been marked as a duplicate of bug 983147 ***

Note You need to log in before you can comment on or make changes to this bug.