Bug 981383 - openstack-packstack: remote cinder deployment doesn't work as packstack doesn't configure keystone service properly [NEEDINFO]
openstack-packstack: remote cinder deployment doesn't work as packstack doesn...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
x86_64 Linux
unspecified Severity high
: rc
: 4.0
Assigned To: Martin Magr
Haim
storage
: Triaged, Unconfirmed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 11:12 EDT by Haim
Modified: 2016-04-26 10:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-07 09:29:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pmyers: needinfo? (hateya)


Attachments (Terms of Use)

  None (edit)
Description Haim 2013-07-04 11:12:55 EDT
Description of problem:

remote cinder deployment doesn't work as packstack doesn't configure correct keystone server. 

in /etc/cinder/cinder.conf

the configuration of keystone was:

 service_host=127.0.0.1

instead of:

service_host=10.35.115.22

I couldn't perform any basic operation due to authentication errors.

ERROR:

2013-07-04 17:39:17  WARNING [keystoneclient.middleware.auth_token] Unexpected response from keystone service: {u'error': {u'message': u'Invalid user / password', u'code': 401, u'title': u'Not Authorized'}}
2013-07-04 17:39:17  WARNING [keystoneclient.middleware.auth_token] Authorization failed for token 040ee745203a4d53be3a87ac68ad5dd6
2013-07-04 17:43:17  WARNING [cinder.openstack.common.policy] Inheritance-based rules are deprecated; use the default brain instead of HttpBrain.


workaround: 

change server to keystone server and restart all services.
Comment 1 Perry Myers 2013-12-05 13:49:48 EST
@haim, can you reproduce this with the RHOS 4.0 latest builds and provide packstack logs?
Comment 2 Martin Magr 2013-12-07 09:29:05 EST
Can't find service_host in cinder.conf sample [1] and service_host is correctly set in api-paste.ini:

[para@virtual-rhel ~]$ sudo cat /etc/cinder/api-paste.ini | grep service_host
service_host=192.168.122.229

So, I'm going to close this one.

[1] https://github.com/openstack/cinder/blob/master/etc/cinder/cinder.conf.sample

Note You need to log in before you can comment on or make changes to this bug.