Bug 981449 - SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'getattr' accesses on the file /run/riak/.erlang.cookie.
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'getatt...
Status: CLOSED DUPLICATE of bug 981448
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e884161579bf92eff6bb144505f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 14:42 EDT by Mark
Modified: 2013-07-07 02:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 02:55:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-07-04 14:42:47 EDT
Description of problem:
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'getattr' accesses on the file /run/riak/.erlang.cookie.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that beam.smp should be allowed getattr access on the .erlang.cookie file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep beam.smp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:var_run_t:s0
Target Objects                /run/riak/.erlang.cookie [ file ]
Source                        beam.smp
Source Path                   /usr/lib64/erlang/erts-5.10.1/bin/beam.smp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           erlang-erts-R16B-0.3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-54.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.x86_64 #1 SMP Thu
                              Jun 27 19:24:23 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-07-04 00:47:23 EDT
Last Seen                     2013-07-04 00:47:25 EDT
Local ID                      135889af-35e8-4386-9d93-c641a09d525a

Raw Audit Messages
type=AVC msg=audit(1372913245.229:829): avc:  denied  { getattr } for  pid=6011 comm="beam.smp" path="/run/riak/.erlang.cookie" dev="tmpfs" ino=33059 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1372913245.229:829): arch=x86_64 syscall=stat success=no exit=EACCES a0=7f5d07b81000 a1=7f5d09d5cd90 a2=7f5d09d5cd90 a3=0 items=0 ppid=6002 pid=6011 auid=4294967295 uid=992 gid=991 euid=992 suid=992 fsuid=992 egid=991 sgid=991 fsgid=991 ses=4294967295 tty=(none) comm=beam.smp exe=/usr/lib64/erlang/erts-5.10.1/bin/beam.smp subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: beam.smp,rabbitmq_beam_t,var_run_t,file,getattr

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-07 02:55:23 EDT

*** This bug has been marked as a duplicate of bug 981448 ***

Note You need to log in before you can comment on or make changes to this bug.