Bug 981458 - Program Will Not Update Itself Once Photos Are Downloaded
Program Will Not Update Itself Once Photos Are Downloaded
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: rapid-photo-downloader (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 15:11 EDT by KitchM
Modified: 2013-08-22 06:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 06:38:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug info (29.25 KB, text/plain)
2013-08-07 20:06 EDT, KitchM
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1206853 None None None Never

  None (edit)
Description KitchM 2013-07-04 15:11:35 EDT
Description of problem:
Once photos are downloaded, the program hangs at that point, and fails to finish its processing.  The screen does not change or update

Version-Release number of selected component (if applicable):
0.4.6

How reproducible:
always

Steps to Reproduce:
1. Plug in camera
2. Open program
3. Download all photos

Actual results:
The screen never changes

Expected results:
The pictures usually disappear since they have been moved from camera view.

Additional info:
Comment 1 KitchM 2013-07-31 10:17:12 EDT
How is this coming along?
Comment 2 Damon Lynch 2013-08-07 14:23:20 EDT
I am the developer of the program. I strongly recommend downloading directly from a memory card and not a camera. If you face any continuing problems you can report bugs here: https://bugs.launchpad.net/rapid/+filebug and be be sure to include the output when running the program from the command line like this: rapid-photo-downloader --debug
Comment 3 KitchM 2013-08-07 14:28:07 EDT
Are you saying the program is not for cameras?
Comment 4 Damon Lynch 2013-08-07 14:31:38 EDT
As is clearly explained in the program itself and on the program's website, downloading directly from cameras is an experimental feature. It works on some cameras and not on others.
Comment 5 KitchM 2013-08-07 14:42:41 EDT
Oh, I must have missed that in the program discription.  My bad.

From the yumex info it states "It does not download images directly from a camera unless the camera is recognized as an external drive".

First of all, my camera is always seen as a storage device by every OS.  Secondly, it has always worked in the past.

I will find something else.

Thanks.
Comment 6 Damon Lynch 2013-08-07 14:48:48 EDT
Unfortunately the OS in which Rapid Photo Downloader runs is a moving target. Gtk and Gnome are constantly changing. Code that used to work without problems stops working. So if you were able to download directly from the camera with Rapid Photo Downloader  before but not now it might not be an problem relating to the camera support. Without a bug report that includes the debugging information it is impossible for me to evaluate your bug report.
Comment 7 KitchM 2013-08-07 20:05:15 EDT
That is quite correct.  That's why good programming is platform independent and always will be.

Because you let me use your software for awhile, I am including the results from my latest download attempt as requested.  Please see attached file.
Comment 8 KitchM 2013-08-07 20:06:30 EDT
Created attachment 784167 [details]
Debug info
Comment 9 Damon Lynch 2013-08-07 22:59:08 EDT
The bug is a trivial one that is triggered when the program tries to uses the OS notification system to display how many photos/videos were downloaded. It's an issue I've seen before, but only in Fedora / Redhat, and it's come up again. I don't recall right now if it's a packaging bug or something related to the code itself.
Comment 10 KitchM 2013-08-08 11:24:12 EDT
Actually, it causes the program to stop working, and then causes ABRT to pop up because of having to exit the program.  So it trivially fails, trivially causes the system to recognize the error and trivially causes the user to wonder what the heck is happening to her pictures being moved.

Trivial indeed.
Comment 11 Damon Lynch 2013-08-08 11:38:11 EDT
Please don't misunderstand me. I'm saying from a coder's perspective, the bug is trivial, and can be fixed in a matter of a few minutes. Compared to other problems, such as those I've already discussed above, it is trivial. From the user's perspective, any time the program exits unexpectedly of course it's a failure. 

Finally, while I thank you for your bug report, and I'm happy if you have found the program useful in some manner, I don't appreciate the tone you're using with me here. I hope you realize I work on this project in my free time and at my own expense. It has taken literally thousands of hours of my time since 2007, when I first started the project.
Comment 12 KitchM 2013-08-08 11:57:28 EDT
Then you shouldn't have thoughtlessly used the word "trivial" and insulted me.  Perhaps surprisingly to you, I don't appreciate being insulted.

I work on supplying feedback for free to all developers who appreciate it, and have done so for thirty years.  And as I stated, I no longer use your product but still went out of my way to help you.

You are not a nice person.
Comment 13 Fabian Affolter 2013-08-22 06:38:32 EDT
Downloading images from an SD card with rapid-photo-downloader 0.4.6 on a fresh Fedora 19 installation works fine.

Note You need to log in before you can comment on or make changes to this bug.