Bug 981513 - Graphical login stopped working in Rawhide 2013-07-04
Graphical login stopped working in Rawhide 2013-07-04
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 22:47 EDT by Adam Williamson
Modified: 2013-07-05 14:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-05 14:34:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-07-04 22:47:52 EDT
I updated Rawhide today, rebooted, and found I could no longer login through GDM. It reports 'authentication failure', even though I'm typing the right password for my user. (Yes, I really, really am). I can log in through a console and run 'startx' just fine.

journalctl -a shows:

Jul 04 19:32:35 adam.localdomain unix_chkpwd[1653]: password check failed for user (adamw)
Jul 04 19:32:35 adam.localdomain gdm-password][1647]: pam_unix(gdm-password:auth): authentication failure; logname=(unknown) uid=0 euid=0 tty=:0 ruser= rhost=  user=adamw
Jul 04 19:33:12 adam.localdomain gdm[588]: GLib-GIO: g_dbus_method_invocation_return_value_internal: assertion 'G_IS_DBUS_METHOD_INVOCATION (invocation)' failed
Jul 04 19:33:12 adam.localdomain unix_chkpwd[1661]: password check failed for user (adamw)
Jul 04 19:33:12 adam.localdomain gdm-password][1654]: pam_unix(gdm-password:auth): authentication failure; logname=(unknown) uid=0 euid=0 tty=:0 ruser= rhost=  user=adamw
Jul 04 19:33:22 adam.localdomain unix_chkpwd[1668]: password check failed for user (adamw)
Jul 04 19:33:22 adam.localdomain gdm-password][1663]: pam_unix(gdm-password:auth): authentication failure; logname=(unknown) uid=0 euid=0 tty=:0 ruser= rhost=  user=adamw

(that's three attempts).

When logging in to a VT I note this error:

Jul 04 19:35:06 adam.localdomain systemd[1418]: Failed at step PAM spawning /usr/lib/systemd/systemd: Operation not permitted

I haven't checked yet if this is an SELinux thing, guess I should.
Comment 1 Adam Williamson 2013-07-05 14:34:27 EDT
D'oh - just realized my keyboard layout was set to 'fr' in gdm due to some localectl testing I did yesterday!

Note You need to log in before you can comment on or make changes to this bug.