Bug 981535 - [PATCH] Substitute %{name} with module name when looking for unused_patches
[PATCH] Substitute %{name} with module name when looking for unused_patches
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpkg (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 01:33 EDT by Siddhesh Poyarekar
Modified: 2015-09-13 20:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-18 07:57:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
candidate patch (605 bytes, patch)
2013-07-05 01:33 EDT, Siddhesh Poyarekar
no flags Details | Diff

  None (edit)
Description Siddhesh Poyarekar 2013-07-05 01:33:41 EDT
Created attachment 769090 [details]
candidate patch

Description of problem:
fedpkg unused-patches currently returns all patches in the tree for glibc because glibc lists the patches as:

Patch: %{name}-rh999999.patch

Attached is a simple patch that substitutes %{name} with the module name before searching for the patch file names in the read in spec file.
Comment 1 Dennis Gilmore 2014-02-18 07:57:45 EST
I have applied you patch plus some additional checks that were missing to upstream git.  Thanks for the report and patch

Note You need to log in before you can comment on or make changes to this bug.