Bug 981554 - Throw an exception when configure "iscsi initiator name" with an empty string.
Throw an exception when configure "iscsi initiator name" with an empty string.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks: 981560
  Show dependency treegraph
 
Reported: 2013-07-05 02:57 EDT by haiyang,dong
Modified: 2014-01-21 14:44 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.0-6.el6
Doc Type: Bug Fix
Doc Text:
When on the Remote Storage page and configuring "iscsi initiator name", an error was generated in the UI saying "Invalid Data" if it was configured with an empty string. The iscsi initiator name doesn't allow an empty string to be used anymore, also setting "Rsyslog address" and "Netconsole address" with an empty string are not permissible and therefore no errors are produced.
Story Points: ---
Clone Of:
: 981560 (view as bug list)
Environment:
Last Closed: 2014-01-21 14:44:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for exception iscsi initiator name.png (3.71 KB, image/png)
2013-07-05 02:57 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16471 None None None Never

  None (edit)
Description haiyang,dong 2013-07-05 02:57:23 EDT
Created attachment 769114 [details]
attached Screenshot for exception iscsi initiator name.png

Description of problem:
Enter Remote Storage page and configure "iscsi initiator name" with an empty string.
Then it throw an exception clicking "Save" to apply what i configured.(Seen exception iscsi initiator name.png)


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1710.el6
ovirt-node-3.0.0-1.999.20130702120359git0015156.el6.noarch

How reproducible:
100%

Steps to Reproduce:


Actual result:

                                                           
Expect result:

Additional info:
similar issue for setting "Rsyslog address" and "Netconsole address" with an empty string
Comment 5 haiyang,dong 2013-10-21 08:02:19 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

Now the iscsi initiator name didn't allow an empty, also setting "Rsyslog address" and "Netconsole address" with an empty string didn't throw an exception

so this bug has been fixed, change the status into "VERIFIED"
Comment 8 Cheryn Tan 2013-11-07 19:33:57 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 14:44:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.