Bug 981597 - "PRODUCT_NAME" arguments not assigned in other device page
"PRODUCT_NAME" arguments not assigned in other device page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 04:45 EDT by cshao
Modified: 2014-01-21 14:44 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-7.el6
Doc Type: Bug Fix
Doc Text:
The "PRODUCT_NAME" argument wasn't assigned in other device page, and should have been assigned as "RHEV Hypervisor". Also the prompt "please select the disk to use for booting PRODUCT_NAME" was inaccurate, it should have read as as "please enter the disk to use for booting RHEV-Hypervisor". The following changes were made: 1. "PRODUCT_NAME" was changed to RHEVH 2. The word "enter" has replaced "select"
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:44:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
product name (14.68 KB, image/png)
2013-07-05 04:45 EDT, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16526 None None None Never

  None (edit)
Description cshao 2013-07-05 04:45:39 EDT
Created attachment 769140 [details]
product name

Description of problem:
1. "PRODUCT_NAME" arguments isn't assigned in other device page, it should be assign as "RHEV Hypervisor".

2. The indication "please select the disk to use for booting PRODUCT_NAME" is inaccurate, it should be show as "please enter the disk to use for booting RHEV-Hypervisor".

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso
ovirt-node-3.0.0-1.999.20130701111251git99aadc6.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Boot from pxe and install RHEV-H 6.5.
2. Enter other device page.
3.

Actual results:
1. "PRODUCT_NAME" arguments isn't assigned in other device page,
2. The indication "please select the disk to use for booting PRODUCT_NAME" is inaccurate.

Expected results:
"please enter the disk to use for booting RHEV-Hypervisor".

Additional info:
Comment 2 haiyang,dong 2013-07-08 21:44:22 EDT
upstream patch:
http://gerrit.ovirt.org/#/c/16526/

Shown the value of variable quantity "PRODUCT_SHORT" instead of
just shown string "PRODUCT_NAME" for the description of CustomDeviceDialog
Comment 4 cshao 2013-10-24 07:01:44 EDT
rhev-hypervisor6-6.5-20131017.0
ovirt-node-3.0.1-4.el6.noarch

1. Boot from pxe and install RHEV-H 6.5.
2. Enter other device page.

"PRODUCT_NAME" have change to RHEVH, but another issue which was discripted in the second "actual result" still existing, because we can't select any disk in "custom block device " page. We only can input the device path but no select.

So it woulder be better if change the word "select" to "enter" or "input".
Thanks!

Change bug status to ASSIGNED.
Comment 5 Fabian Deutsch 2013-10-30 08:22:16 EDT
Use "enter" instead of "select":

http://gerrit.ovirt.org/#/c/20696/
Comment 7 Cheryn Tan 2013-11-07 19:32:39 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 cshao 2013-11-08 00:31:56 EST
Test version:
rhevh-6.5-20131031.1.0
ovirt-node-3.0.1-7.el6.noarch

1. Boot from pxe and install RHEV-H 6.5.
2. Enter other device page.

Test result:
1. "PRODUCT_NAME" have change to RHEVH
2. The word "enter" has replaced "select"

So the bug is fixed, change bug status to VERIFIED.
Comment 10 errata-xmlrpc 2014-01-21 14:44:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.