Bug 981602 - Kobo Deluxe claims group id outside of system accounts range.
Kobo Deluxe claims group id outside of system accounts range.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: KoboDeluxe (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 05:04 EDT by Marcel Metz
Modified: 2013-07-05 09:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-05 09:40:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Let the spec file create a kobodl system group instead of a user group. (644 bytes, patch)
2013-07-05 05:04 EDT, Marcel Metz
no flags Details | Diff

  None (edit)
Description Marcel Metz 2013-07-05 05:04:02 EDT
Created attachment 769151 [details]
Let the spec file create a kobodl system group instead of a user group.

Description of problem:
When installing Kobo Deluxe via yum a group `kobodl` is created. However the group lies outside of the range for system user accounts as defined in /etc/logins.defs, creating a potential for colliding group ids. In my case the user group id of my primary account of an fedora 17 installation with separate /home partition collides with a new installation of fedora 19, because the kobodl group was created before my user account in question.

Version-Release number of selected component (if applicable):
0.5.1-11.fc19

How reproducible:
Install KoboDeluxe and compare the kobodl gid with the limitations of /etc/login.defs

Steps to Reproduce:
1. yum install KoboDeluxe
2. Compare output of `grep kobodl /etc/group` and `grep 'SYS_GID_\(MIN\|MAX\)' /etc/login.defs`

Actual results:
The group id of kobodl lies outside of SYS_GID_MIN and SYS_GID_MAX.

Expected results:
The group id of kobodl should lie between SYS_GID_MIN and SYS_GID_MAX.

Additional info:
The packaging policies for users and groups[1] state, that the dynamic allocation for groups should use the -r flag of addgroup, which tells addgroup to create 'system groups'.

The attached unified patch implements the change in the spec file as suggested in the wiki article.

[1] http://fedoraproject.org/wiki/Packaging:UsersAndGroups#Dynamic_allocation
Comment 1 Hans de Goede 2013-07-05 09:40:17 EDT
Thanks for the patch!

Applied and build for rawhide.

Note You need to log in before you can comment on or make changes to this bug.