Bug 981603 - [RFE] Should better to rearrange the page when more error info is provided
[RFE] Should better to rearrange the page when more error info is provided
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Ryan Barry
Virtualization Bugs
node
: FutureFeature, UserExperience
: 1065439 (view as bug list)
Depends On:
Blocks: 981267 1092879
  Show dependency treegraph
 
Reported: 2013-07-05 05:04 EDT by wanghui
Modified: 2016-02-10 15:11 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1092879 (view as bug list)
Environment:
Last Closed: 2015-09-25 05:31:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sherold: Triaged+


Attachments (Terms of Use)
rearrang-page (56.68 KB, image/png)
2013-07-05 05:04 EDT, wanghui
no flags Details

  None (edit)
Description wanghui 2013-07-05 05:04:12 EDT
Created attachment 769152 [details]
rearrang-page

Description of problem:
It should be better to rearrange the page when there is more than one error info displayed. Like in Network page, when there is more than one error info, the selection icon will disappear.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1711.el6
ovirt-node-3.0.0-1.999.20130702120359git0015156.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean install rhev-hypervisor6-6.5-20130222.0.auto1711.el6.
2. Enter invalid hostname and DNS server address.
3. Check the page.

Actual results:
In step3, the selection icon is diappeared.

Expected results:
In step3, the selection icon can be displayed or can be get in another page.

Additional info:
it will be no such issue when you do ssh connection cause you can resize the screen as you wish. But this will be inconvenient for the host user.
Comment 2 Mike Burns 2013-07-08 09:19:32 EDT
Fabian,  any thoughts?
Comment 3 Fabian Deutsch 2013-07-19 05:44:01 EDT
An idea would be to reduce the signaling about invalid data to a single char at the end of the field (so we don't waste more lines by displaying error messages) e.g:

Address: 129.___________  X

And only show the actual message when the entry is in focus. The single char could be e.g. have a red color to highlight it and would always be visible as long as the field contains invalid data.
Comment 5 Guohua Ouyang 2013-10-21 04:49:23 EDT
(In reply to Fabian Deutsch from comment #3)
> An idea would be to reduce the signaling about invalid data to a single char
> at the end of the field (so we don't waste more lines by displaying error
> messages) e.g:
> 
> Address: 129.___________  X
> 
> And only show the actual message when the entry is in focus. The single char
> could be e.g. have a red color to highlight it and would always be visible
> as long as the field contains invalid data.

The "X" mostly means it's incorrect or unacceptable. When user input an simple password on Security page, The solution maybe not suitable.


And, most pages are very seldom to hit this problem unless users do it purposely.
But not for the security page, user can hit it very often because we may just input simple password at trial or testing environment and get a bad experience.

So if we can fix this single page for 6.5 would be much better.
Comment 6 Fabian Deutsch 2014-04-30 04:48:53 EDT
*** Bug 1065439 has been marked as a duplicate of this bug. ***
Comment 7 Einav Cohen 2014-05-12 15:10:13 EDT
(In reply to Fabian Deutsch from comment #3)
> An idea would be to reduce the signaling about invalid data to a single char
> at the end of the field (so we don't waste more lines by displaying error
> messages) e.g:
> 
> Address: 129.___________  X
> 
> And only show the actual message when the entry is in focus. The single char
> could be e.g. have a red color to highlight it and would always be visible
> as long as the field contains invalid data.

not a big expert on TUI, but 'X' may also imply a 'delete' action or something similar. 
instead, maybe a "!" or "[!]" (if "!" is too narrow). 

Address: 129.___________  !

-or-

Address: 129.___________  [!]

rest of the suggestion seems fine (red color, show full message upon selection/focus).
Comment 8 Fabian Deutsch 2014-05-12 16:56:30 EDT
Hey Einav,

thanks that sounds like a great idea. I like the visualization using the exclamation mark.
Comment 9 Fabian Deutsch 2015-09-25 05:31:34 EDT
In future the functionality affected by this bug will move to a different component (likely cockpit), thus this bug will be closed.

Please re-open if you think this is really necessary.

Note You need to log in before you can comment on or make changes to this bug.