Bug 981623 - qemu-kvm shows conflict with qemu-kvm-rhev but upgrade to it successfully, qemu-kvm-debuginfo just opposite
qemu-kvm shows conflict with qemu-kvm-rhev but upgrade to it successfully, qe...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 06:06 EDT by Qunfang Zhang
Modified: 2013-10-01 10:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 10:26:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2013-07-05 06:06:08 EDT
Description of problem:
"rpm -q qemu-kvm --conflicts" shows it conflicts with qemu-kvm-rhev, but upgrade qemu-kvm to higer version qemu-kvm-rhev successfully. And for the qemu-kvm-debuginfo packages, it does not conflict with any, but failed to upgrade to qemu-kvm-rhev-debuginfo due to conflict.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.377.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install qemu-kvm, qemu-img, qemu-kvm-tools with -375 version.
# rpm -qa | grep qemu
qemu-img-0.12.1.2-2.375.el6.x86_64
gpxe-roms-qemu-0.9.7-6.9.el6.noarch
qemu-kvm-tools-0.12.1.2-2.375.el6.x86_64
qemu-kvm-0.12.1.2-2.375.el6.x86_64

2. # rpm -q qemu-kvm --conflicts
qemu-kvm-rhev  
vdsm < 4.5

3. Upgrade the packages to qemu-kvm-rhev-377 version.
# rpm -Uvh qemu-kvm-rhev-377/*
Preparing...                ########################################### [100%]
   1:qemu-img-rhev          ########################################### [ 33%]
   2:qemu-kvm-rhev          ########################################### [ 67%]
   3:qemu-kvm-rhev-tools    ########################################### [100%]
# rpm -qa | grep qemu
qemu-kvm-rhev-0.12.1.2-2.377.el6.x86_64
gpxe-roms-qemu-0.9.7-6.9.el6.noarch
qemu-kvm-rhev-tools-0.12.1.2-2.377.el6.x86_64
qemu-img-rhev-0.12.1.2-2.377.el6.x86_64
# 

4. Install qemu-kvm-debuginfo-375
# rpm -ivh qemu-kvm-375/qemu-kvm-debuginfo-0.12.1.2-2.375.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
   1:qemu-kvm-debuginfo     ########################################### [100%]

5. Check the conflict:
# rpm -q qemu-kvm-debuginfo --conflicts
# 
(No things return)

6. Upgrade to qemu-kvm-rhev-debuginfo-377
# rpm -Uvh qemu-kvm-rhev-debuginfo-0.12.1.2-2.377.el6.x86_64.rpm 
Preparing...                ########################################### [100%]
	file /usr/lib/debug/usr/bin/qemu-img.debug from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/lib/debug/usr/bin/qemu-io.debug from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/lib/debug/usr/libexec/qemu-kvm.debug from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/block.c from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/block.h from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/block/qcow2-cluster.c from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/blockdev.c from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/hw/device-assignment.c from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-disk.c from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/os-posix.c from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/osdep.c from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/osdep.h from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/qemu-config.c from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/qemu-config.h from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/sysemu.h from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64
	file /usr/src/debug/qemu-kvm-0.12.1.2/vl.c from install of qemu-kvm-rhev-debuginfo-2:0.12.1.2-2.377.el6.x86_64 conflicts with file from package qemu-kvm-debuginfo-2:0.12.1.2-2.375.el6.x86_64



Actual results:
Check each result in each step.

Expected results:
If "rpm -q qemu-kvm(-rhev) --conflicts"[1] shows something conflict, then should not upgrade to the conflict version. 
If does not return something in [1], then should upgrade successfully.

Additional info:
Comment 2 Michal Novotny 2013-08-09 11:21:10 EDT
I've been testing it now and it seems the conflict is provided bad package name in the RHEV case and therefore it didn't fail.

The RHEL (qemu-kvm) conflicts output is:

# rpm -q qemu-kvm --conflicts
qemu-kvm-rhev  
vdsm < 4.5
#

However the RHEV output (qemu-kvm-rhev) conflicts output is:

# rpm -q qemu-kvm-rhev --conflicts
qemu-kvm-rhel  
qemu-kvm <= 2:0.12.1.2-2.352.el6
vdsm < 4.5
#

The qemu-kvm-rhel name is not valid so I'm currently working on it.

Michal
Comment 4 Miroslav Rezanina 2013-10-01 06:49:17 EDT
After testing and discuss with pmatilai get this result:

1) We use Obsoletes in rhev to prefer qemu-kvm-rhev in case both rhel and rhev repo are available. This tag overides Conflicts when doing update (rpm -U or yum install (this automatically remove qemu-kvm)). Obsoletes is not used for rpm -i.

2) Debuginfo packages conflict on file level not rpm level so this is not represented by Conflicts tag. In addition, it is package generated automatically by rpmbuild in case debugging information are available.


Due to this fact we can close the BZ as NOTABUG in case we want allow user to update from qemu-kvm to qemu-kvm-rhev. If we require manual uninstall qemu-kvm
before qemu-kvm-rhev is installed, this will be fixed. Debuginfo package behavior is beyond our control.
Comment 5 Ademar Reis 2013-10-01 10:26:11 EDT
(In reply to Miroslav Rezanina from comment #4)
> After testing and discuss with pmatilai get this result:
> 
> 1) We use Obsoletes in rhev to prefer qemu-kvm-rhev in case both rhel and
> rhev repo are available. This tag overides Conflicts when doing update (rpm
> -U or yum install (this automatically remove qemu-kvm)). Obsoletes is not
> used for rpm -i.
> 
> 2) Debuginfo packages conflict on file level not rpm level so this is not
> represented by Conflicts tag. In addition, it is package generated
> automatically by rpmbuild in case debugging information are available.
> 
> 
> Due to this fact we can close the BZ as NOTABUG in case we want allow user
> to update from qemu-kvm to qemu-kvm-rhev. If we require manual uninstall
> qemu-kvm
> before qemu-kvm-rhev is installed, this will be fixed. Debuginfo package
> behavior is beyond our control.

Agree.

Note You need to log in before you can comment on or make changes to this bug.