Bug 981653 - quota: crash in glusterd after list command fails
quota: crash in glusterd after list command fails
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
Saurabh
:
Depends On: 983544
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 08:16 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta4_1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-07-05 08:16:28 EDT
Description of problem:


Version-Release number of selected component (if applicable):
[root@quota1 ~]# rpm -qa | grep glusterfs
glusterfs-fuse-3.4.0.12rhs.beta2-1.el6rhs.x86_64
glusterfs-server-3.4.0.12rhs.beta2-1.el6rhs.x86_64
glusterfs-debuginfo-3.4.0.12rhs.beta2-1.el6rhs.x86_64
glusterfs-3.4.0.12rhs.beta2-1.el6rhs.x86_64
[root@quota1 ~]# 


How reproducible:
executed the test first time

Steps to Reproduce:
1. create a volume, start it
2. enable quota, set some limit
3. mount the volume over nfs.
4. create 500 directories and inside these 500 directories, create one more sub-dir in each dir.
5. set limit on each dir and subdir as 2GB and 1GB each.
6. gluster volume quota <vol-name> list

Actual results:
step 6, the quota command fails
gluster volume status 
fails as glusterd is not operational

on a keener look, there is a crash.


Expected results:

list command should succeed for whatever be the number of directories and in this it is just 500 directories + 500 subdirs

Additional info:
Comment 3 Krutika Dhananjay 2013-07-08 12:07:05 EDT
https://code.engineering.redhat.com/gerrit/#/c/9875/ <--- Posted for review in downstream
Comment 5 Scott Haines 2013-09-23 18:39:54 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:43:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.