Bug 981676 - Pulp fails to install on rhel6
Pulp fails to install on rhel6
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: rel-eng (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity high
: ---
: 2.2.0
Assigned To: Jeff Ortel
Preethi Thomas
: Triaged
: 976568 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 09:03 EDT by Preethi Thomas
Modified: 2013-09-10 11:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 11:43:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2013-07-05 09:03:32 EDT
Description: 
Install of pulp on RHEL6 fails with 
Error: Package: createrepo-0.9.9-21.el6.noarch (pulp-v2-testing)
           Requires: yum >= 3.4.3-4
           Installed: yum-3.2.29-40.el6.noarch (@anaconda-RedHatEnterpriseLinux-201301301459.x86_64/6.4)
               yum = 3.2.29-40.el6


Packages to be added: 

Comps group:  

Default: 

Mandatory: 

Visible: 

Multi-lib: 

Need to be present for arches:
Comment 1 Michael Hrivnak 2013-07-05 10:01:44 EDT
Here's further evidence:

$ rpm -qpR http://repos.fedorapeople.org/repos/pulp/pulp/v2/testing/6Server/x86_64/createrepo-0.9.9-21.el6.noarch.rpm
/bin/sh
/usr/bin/python
deltarpm
libxml2-python
pyliblzma
python >= 2.1
python(abi) = 2.6
python-deltarpm
rpm >= 4.1.1
rpm-python
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
yum >= 3.4.3-4
yum-metadata-parser
rpmlib(PayloadIsXz) <= 5.2-1
Comment 2 Jeff Ortel 2013-07-08 15:59:36 EDT
https://github.com/pulp/pulp/pull/528
Comment 3 Jeff Ortel 2013-07-08 16:00:45 EDT
build: 2.2.0-0.19.beta

See: createrepo-0.9.9-21.2.pulp
Comment 4 Preethi Thomas 2013-07-09 08:45:33 EDT
verified
[root@ibm-x3550m3-07 ~]# rpm -qa |grep pulp
python-pulp-rpm-common-2.2.0-0.19.beta.el6.noarch
createrepo-0.9.9-21.2.pulp.el6.noarch
python-rhsm-1.8.0-1.pulp.el6.x86_64
pulp-selinux-2.2.0-0.19.beta.el6.noarch
python-isodate-0.5.0-1.pulp.el6.noarch
m2crypto-0.21.1.pulp-8.el6.x86_64
python-pulp-puppet-common-2.2.0-0.19.beta.el6.noarch
python-pulp-rpm-extension-2.2.0-0.19.beta.el6.noarch
python-pulp-client-lib-2.2.0-0.19.beta.el6.noarch
python-pulp-bindings-2.2.0-0.19.beta.el6.noarch
pulp-admin-client-2.2.0-0.19.beta.el6.noarch
mod_wsgi-3.4-1.pulp.el6.x86_64
pulp-server-2.2.0-0.19.beta.el6.noarch
pulp-puppet-plugins-2.2.0-0.19.beta.el6.noarch
pulp-rpm-admin-extensions-2.2.0-0.19.beta.el6.noarch
python-pulp-common-2.2.0-0.19.beta.el6.noarch
python-oauth2-1.5.170-3.pulp.el6.noarch
pulp-builtins-admin-extensions-2.2.0-0.19.beta.el6.noarch
pulp-rpm-plugins-2.2.0-0.19.beta.el6.noarch
pulp-puppet-admin-extensions-2.2.0-0.19.beta.el6.noarch
[root@ibm-x3550m3-07 ~]# rpm -qa |grep createrepo
createrepo-0.9.9-21.2.pulp.el6.noarch
[root@ibm-x3550m3-07 ~]# 
[root@ibm-x3550m3-07 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.4 (Santiago)
[root@ibm-x3550m3-07 ~]#
Comment 5 Preethi Thomas 2013-07-09 13:53:14 EDT
*** Bug 976568 has been marked as a duplicate of this bug. ***
Comment 6 Preethi Thomas 2013-09-10 11:43:47 EDT
2.2 released
http://repos.fedorapeople.org/repos/pulp/pulp/stable/2.2/

Note You need to log in before you can comment on or make changes to this bug.