Bug 981735 - Nodes with non-ASCII names cannot be accessed
Nodes with non-ASCII names cannot be accessed
Status: CLOSED DEFERRED
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium
: ER04
: 6.1.0
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 12:00 EDT by Miroslav Cupák
Modified: 2015-01-05 06:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 10:51:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GTNPORTAL-3200 Major Resolved Non-Ascii node names are not routed properly. 2013-09-06 00:18:44 EDT

  None (edit)
Description Miroslav Cupák 2013-07-05 12:00:03 EDT
Description of problem:
The portal allows for creation of nodes whose names contain non-ASCII characters, but the pages cannot be accessed - the first node in the navigation is shown instead. The same goes for dashboard pages.

Steps to Reproduce:
1. Start the portal and sign in as root.
2. Go to Site Editor > Add New Page.
3. Create e.g. a top-level page with the name "ábá" and save it.
4. Try to access the page through the navigation.
Comment 2 Boleslaw Dawidowicz 2013-07-24 10:51:35 EDT
Nick worked on the fix and it will be available in GateIn master. 

At this stage it seems to be too risky to be included because of possible regressions.

Note You need to log in before you can comment on or make changes to this bug.