Bug 981742 - Bluetooth A2DP audio stopped working in Fedora 19
Bluetooth A2DP audio stopped working in Fedora 19
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 12:44 EDT by Vadim Trochinsky
Modified: 2013-07-06 17:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-06 17:21:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Trochinsky 2013-07-05 12:44:32 EDT
Description of problem:

I use the Sennheiser MM550 bluetooth headphones. They support both the telephony and A2DP profiles.

In Fedora 18 A2DP worked perfectly fine. As of the upgrade, it fails to work. The headset uses "Telephony Duplex (HSP/HFP)" when it associates. Changing to A2DP via pavucontrol results in no sound.



How reproducible:

Happens with 100% consistency


Steps to Reproduce:
1. Associate headphones
2. Play sound. Notice the quality is bad.
3. Check Configuration tab of pavucontrol
4. Try to change profile to A2DP


Actual results:

Sound stops playing. On the first attempt to change to A2DP, the selection automatically changes to "Off". On subsequent attempts, A2DP remains selected, but still doesn't work. Reconnecting the headphones or any other actions result in HSP/HFP getting used again.


Expected results:

Headphones should work in A2DP mode.

Additional info:

Logs while associating:

Jul  5 18:40:08 madhatter kernel: [ 9162.860711] Bluetooth: Wrong link type (-71)
Jul  5 18:40:16 madhatter kernel: [ 9170.738314] input: 00:16:94:0B:70:BA as /devices/virtual/input/input16
Jul  5 18:40:17 madhatter bluetoothd[22295]: bluetoothd[22295]: /org/bluez/22295/hci0/dev_00_16_94_0B_70_BA/fd2: fd(30) ready
Jul  5 18:40:17 madhatter bluetoothd[22295]: /org/bluez/22295/hci0/dev_00_16_94_0B_70_BA/fd2: fd(30) ready


On trying to change to A2DP:
Jul  5 18:41:00 madhatter bluetoothd[22295]: bluetoothd[22295]: Audio connection got disconnected
Jul  5 18:41:00 madhatter bluetoothd[22295]: Audio connection got disconnected
Jul  5 18:41:00 madhatter pulseaudio[2142]: [pulseaudio] module-bluetooth-device.c: Profile has no transport
Comment 1 Vadim Trochinsky 2013-07-06 17:21:20 EDT
Oops. Looks like something in the configuration changed in the release, and there was a .rpmnew file that made everything work again.

Note You need to log in before you can comment on or make changes to this bug.