Bug 981760 - Unable to set wallpaper
Unable to set wallpaper
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 14:04 EDT by Luca Giuzzi
Modified: 2015-02-12 06:13 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-12 06:13:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 702283 None None None Never

  None (edit)
Description Luca Giuzzi 2013-07-05 14:04:27 EDT
Description of problem:

On older machines I am unable to set the background wallpaper of
gnome to an arbitrary file on older machines (VRAM<256 Mb) as well as
on a recent atom laptop.


Version-Release number of selected component (if applicable):

F19

How reproducible:


Steps to Reproduce:
1. Select a picture as a background wallpaper
2. Check the preview and confirm
3.

Actual results:

The background wallpaper is set to some uniform tint

Expected results:

The background is expected to be set to the appropriate picture.

Additional info:

I expect that the culprit is a limit on size of textures on these machines.
[the videocards were an ATI RC410, an ATI RV370 and the standard
Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller - in this case the processor is actually an N570]

Incidentally, I have had no issues with an ATI RV635/M86 (Radeon HD3650).




Is there any workaround?
Comment 1 Fedora Admin XMLRPC Client 2013-09-23 12:36:30 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Kalev Lember 2013-09-24 21:01:34 EDT
Hi Luca,

Have you gotten this working in the mean time, by any chance? I don't really know how to help you debug this, but we should reassign the ticket to the graphics stack instead -- the gnome-backgrounds package probably has nothing to do with the issue, it just ships the .jpg files.
Comment 3 Luca Giuzzi 2013-10-03 14:23:16 EDT
Hi,
 no: the bug is still there. 
 I believe it has to do with texture size, as the only backgrounds which work
 are those whose size is approx. less or equal to 1920x1200 pixels.
 e.g. among the standard wallpapers, bee-and-the-sunflower.jpg, diamantina.jpg and water-flower.jpg work; cherry-2.jpg or wine-in-the-morning.jpg do not.
If I manually resize an image, by downscaling it, then it appears it can be loaded.

[I tried this with wine-in-the-morning.jpg with a
convert /usr/share/backgrounds/schroedinger-cat/extras/wine-in-the-morning.jpg ~/wine-in-the-morning-resized.jpg 
and then I could manage to load it]

I reckon that the proper fix would be to downscale the image before loading it when the screen resolution is low, but I do not know how manageable this might be with the current stack.
Comment 4 Kalev Lember 2013-10-22 07:26:55 EDT
Reassigning to Mutter that draws the background. This is likely already fixed upstream with https://git.gnome.org/browse/mutter/commit/?id=15e01152da335f5a9e7617674ffa54cb1bdef957
Comment 5 Peter Robinson 2013-10-22 07:53:47 EDT
I've seen this issue as well on a fully updated F-19 machine. I don't believe it's an issue due to memory as the machine I saw this on had 3Gb. I tried to down scale the image and it didn't have much effect, I think it might also be more related to the image format as there's one image that I can consistently set as the background on this machine and others that I can't.

Interestingly I've seen something similar of late on F-20 where the screen lock image disappears and I get a blue background.
Comment 6 Luca Giuzzi 2014-01-26 12:56:00 EST
So far, I have not seen the problem anymore on F20, at least for what concerns the desktop background.
Comment 7 Fedora End Of Life 2015-01-09 13:41:49 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Note You need to log in before you can comment on or make changes to this bug.