Bug 981786 - Missing QVTKWidget and QVTKWidget2 python bindings in VTK 5.10.1
Missing QVTKWidget and QVTKWidget2 python bindings in VTK 5.10.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vtk (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 15:54 EDT by Michka Popoff
Modified: 2013-08-19 17:30 EDT (History)
4 users (show)

See Also:
Fixed In Version: vtk-5.10.1-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 17:30:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michka Popoff 2013-07-05 15:54:56 EDT
Description of problem:

Using VTK 5.10.1 with python bindings, QVTKWidget and QVTKWidget2 are not built, so they can not be used.

Version-Release number of selected component (if applicable):

5.10.1

How reproducible:

Always

Steps to Reproduce:
In terminal type :
1. python
2. from vtk import QVTKWidget

Actual results:

Traceback (most recent call last) :
  File "<stdin>", line 1, in <module>
ImportError: cannot import name QVTKWidget

Proposed solution :

During build with cmake, these options should be turned on :
VTK_WRAP_PYTHON_SIP=ON for QVTKWidget
VTK_USE_QVTK_QTOPENGL=ON for QVTKWidget2
SIP_PYQT_DIR should also be defined
Comment 1 Fedora Update System 2013-07-29 22:35:37 EDT
vtk-5.10.1-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/vtk-5.10.1-5.fc19
Comment 2 Fedora Update System 2013-08-01 23:53:22 EDT
Package vtk-5.10.1-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vtk-5.10.1-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14060/vtk-5.10.1-5.fc19
then log in and leave karma (feedback).
Comment 3 Michka Popoff 2013-08-19 05:09:42 EDT
Okay works for me. I left karma.
Comment 4 Fedora Update System 2013-08-19 17:30:14 EDT
vtk-5.10.1-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.