Bug 981854 - [abrt] openslides-1.3-4.fc19: pkg_resources.py:594:resolve:DistributionNotFound: pil
[abrt] openslides-1.3-4.fc19: pkg_resources.py:594:resolve:DistributionNotFou...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openslides (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
abrt_hash:9616d7f5b92979005c7d658511e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 07:35 EDT by Christian Stadelmann
Modified: 2013-07-26 19:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: openslides-1.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 19:08:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.04 KB, text/plain)
2013-07-06 07:36 EDT, Christian Stadelmann
no flags Details
File: core_backtrace (398 bytes, text/plain)
2013-07-06 07:36 EDT, Christian Stadelmann
no flags Details
File: environ (4.21 KB, text/plain)
2013-07-06 07:36 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2013-07-06 07:35:57 EDT
Description of problem:
Starting OpenSlides crashes every time no matter what I do (even with --help parameter)

Version-Release number of selected component:
openslides-1.3-4.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/openslides --help
dso_list:       python-setuptools-0.6.36-1.fc19.noarch
executable:     /usr/bin/openslides
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
pkg_resources.py:594:resolve:DistributionNotFound: pil

Traceback (most recent call last):
  File "/usr/bin/openslides", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2805, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 696, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 594, in resolve
    raise DistributionNotFound(req)
DistributionNotFound: pil

Local variables in innermost frame:
dist: None
to_activate: [openslides 1.3 (/usr/lib/python2.7/site-packages)]
req: Requirement.parse('pil')
requirements: [Requirement.parse('reportlab'), Requirement.parse('django-mptt'), Requirement.parse('django>=1.4')]
processed: {Requirement.parse('openslides==1.3'): True}
env: <pkg_resources.Environment object at 0xa2b650>
installer: None
self: <pkg_resources.WorkingSet object at 0xa2b0d0>
best: {'pil': None}
replacement: True
Comment 1 Christian Stadelmann 2013-07-06 07:36:00 EDT
Created attachment 769559 [details]
File: backtrace
Comment 2 Christian Stadelmann 2013-07-06 07:36:03 EDT
Created attachment 769560 [details]
File: core_backtrace
Comment 3 Christian Stadelmann 2013-07-06 07:36:05 EDT
Created attachment 769561 [details]
File: environ
Comment 4 Fedora Update System 2013-07-08 02:56:53 EDT
openslides-1.3.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openslides-1.3.1-1.fc19
Comment 5 Matthias Runge 2013-07-08 02:58:56 EDT
Thanks for the report, the issue should be fixed with this update. Could you please try that and provide feedback?
Comment 6 Christian Stadelmann 2013-07-08 06:40:05 EDT
I can't install your update since it requires python-django14 which conflicts with python-django-1.5.1-1.fc19.noarch and I need that for some other packages installed.

Seems like django 1.5 support was added only 4 months ago (https://github.com/OpenSlides/OpenSlides/pull/547) but openslides 1.3.1 was released 6 months ago (https://github.com/OpenSlides/OpenSlides/releases).

So seems like either python-django14 needs to be fixed not to conflict with python-django 1.5 or openSlides 1.4RC1 be packaged to fedora 19
Comment 7 Christian Stadelmann 2013-07-08 06:51:11 EDT
Ok, those other packages depending on python-django 1.5 were not important to me, uninstalled them and installed your new openslides 1.3.1 release. Works fine, thanks for fixing it that fast!
Comment 8 Fedora Update System 2013-07-08 21:42:16 EDT
Package openslides-1.3.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openslides-1.3.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12644/openslides-1.3.1-1.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-07-26 19:08:30 EDT
openslides-1.3.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.