Bug 981885 - Python segmentation fault when trying to start calibre
Python segmentation fault when trying to start calibre
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
19
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 12:45 EDT by Erick
Modified: 2013-07-07 14:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 14:27:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of calibre startup (350.96 KB, text/plain)
2013-07-06 12:45 EDT, Erick
no flags Details
calibre as nonroot (351.26 KB, text/plain)
2013-07-06 14:00 EDT, Erick
no flags Details

  None (edit)
Description Erick 2013-07-06 12:45:29 EDT
Created attachment 769684 [details]
strace of calibre startup

Description of problem:

After last yum update calibre gives a python2 segmentation fault in /var/log/messages


Version-Release number of selected component (if applicable): 

calibre-0.9.34-1.fc19


How reproducible:

Steps to Reproduce:
1. open bash
2. try to run calibre
3. 

Actual results:

consistent segmentation fault

Expected results:

working calibre


Additional info:

/var/log/messages:

kernel: [ 1998.499552] python2[3588]: segfault at 54 ip 4cfd4695 sp bf971ea0 error 4 in ld-2.17.so[4cfc9000+1f000]
Comment 1 Kevin Fenzi 2013-07-06 13:44:41 EDT
So, this started happening after a recent yum update? 
Can you look at /var/log/yum.log and see what packages were updated there? 

Calibre shouldn't have updated, as this is the version in the base fedora 19 repo and I've not pushed any updates to it since then. 

I also see you are running as root? 
Thats probibly a pretty bad idea... can you run it as a normal user and see if the problem persists?
Comment 2 Erick 2013-07-06 13:53:30 EDT
Hi Kevin,

herewith the last updates:

Jul 06 06:45:14 Updated: 2:libwbclient-4.0.7-1.fc19.i686
Jul 06 06:45:17 Updated: 12:dhcp-libs-4.2.5-15.fc19.i686
Jul 06 06:45:18 Updated: 12:dhcp-common-4.2.5-15.fc19.i686
Jul 06 06:45:19 Updated: python-sssdconfig-1.10.0-16.fc19.noarch
Jul 06 06:45:21 Updated: libldb-1.1.16-1.fc19.i686
Jul 06 06:45:25 Updated: 2:samba-libs-4.0.7-1.fc19.i686
Jul 06 06:45:28 Updated: 2:samba-common-4.0.7-1.fc19.i686
Jul 06 06:45:29 Updated: libsss_idmap-1.10.0-16.fc19.i686
Jul 06 06:45:31 Updated: 2:libsmbclient-4.0.7-1.fc19.i686
Jul 06 06:45:33 Updated: 2:samba-winbind-4.0.7-1.fc19.i686
Jul 06 06:45:34 Updated: libipa_hbac-1.10.0-16.fc19.i686
Jul 06 06:45:34 Updated: kernel-tools-libs-3.9.9-301.fc19.i686
Jul 06 06:45:37 Updated: sssd-client-1.10.0-16.fc19.i686
Jul 06 06:45:39 Updated: 2:samba-winbind-clients-4.0.7-1.fc19.i686
Jul 06 06:45:43 Updated: 2:samba-client-4.0.7-1.fc19.i686
Jul 06 06:45:46 Updated: 12:dhclient-4.2.5-15.fc19.i686
Jul 06 06:45:57 Updated: kernel-headers-3.9.9-301.fc19.i686
Jul 06 06:56:24 Installed: kernel-PAE-devel-3.9.9-301.fc19.i686
Jul 06 06:56:27 Updated: hwdata-0.249-1.fc19.noarch
Jul 06 07:07:22 Installed: kernel-devel-3.9.9-301.fc19.i686
Jul 06 07:07:32 Updated: sssd-common-1.10.0-16.fc19.i686
Jul 06 07:07:33 Updated: sssd-krb5-common-1.10.0-16.fc19.i686
Jul 06 07:07:34 Updated: sssd-ad-1.10.0-16.fc19.i686
Jul 06 07:07:35 Updated: sssd-ldap-1.10.0-16.fc19.i686
Jul 06 07:07:36 Updated: sssd-ipa-1.10.0-16.fc19.i686
Jul 06 07:07:37 Updated: sssd-krb5-1.10.0-16.fc19.i686
Jul 06 07:07:38 Updated: sssd-proxy-1.10.0-16.fc19.i686
Jul 06 07:07:38 Updated: sssd-1.10.0-16.fc19.i686
Jul 06 07:07:42 Updated: kernel-tools-3.9.9-301.fc19.i686
Jul 06 07:07:43 Updated: libiscsi-1.7.0-5.fc19.i686
Jul 06 07:08:16 Installed: kernel-PAE-3.9.9-301.fc19.i686
Jul 06 07:08:19 Updated: perf-3.9.9-301.fc19.i686

I ran as root to make sure that no permission issues were in the way. The segfault error was first noticeable when running as my default user erick.

In the meantime I tried reinstalling calibre through yum. No success.
Yesterday evening I used calibre under my default user account without any trouble.
Comment 3 Erick 2013-07-06 14:00:04 EDT
Created attachment 769699 [details]
calibre as nonroot

to enable checking the segfault when running calibre as a nonroot user herewith this strace.
Comment 4 Erick 2013-07-07 12:28:23 EDT
bug can be closed:

Somehow the libqzeitgeist libraries in /usr/lib got lost when deinstalling zeitgeist and calibre depends on libqzeitgeist.
Comment 5 Kevin Fenzi 2013-07-07 14:27:56 EDT
ok. Thanks for letting me know.

Note You need to log in before you can comment on or make changes to this bug.