Bug 981888 - Race condition in make -j8 install—glusterfs-3.4.0beta4
Race condition in make -j8 install—glusterfs-3.4.0beta4
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
3.4.0-beta
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Tiziano Müller
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 14:13 EDT by Kerrick Staley
Modified: 2014-04-17 09:13 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 09:13:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output when running make -j8 (2.31 KB, text/plain)
2013-07-06 14:13 EDT, Kerrick Staley
no flags Details
glusterfs-3.4.0-parallel-build.patch (951 bytes, patch)
2013-07-26 08:00 EDT, Tiziano Müller
no flags Details | Diff

  None (edit)
Description Kerrick Staley 2013-07-06 14:13:35 EDT
Created attachment 769700 [details]
Output when running make -j8

make -j8 install fails; however, make -j1 install succeeds. Attached is a log of the output when running make -j8.
Comment 1 Tiziano Müller 2013-07-26 08:00:18 EDT
Created attachment 778747 [details]
glusterfs-3.4.0-parallel-build.patch

The culprit is a bug in automake, see also http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7328
The same problem was also present in spice-gtk, see http://comments.gmane.org/gmane.comp.emulators.spice.devel/13178

The attached patch fixes it for glusterfs-3.4.0
Comment 2 Niels de Vos 2013-07-26 10:42:09 EDT
Tiziano, are you interested in pushing the patch through the Gerrit interface so that it can get merged under your name?

See http://www.gluster.org/community/documentation/index.php/Development_Work_Flow for details. If you have difficulties, send an email to gluster-devel@nongnu.org or ask on IRC/Freenode in #gluster/#gluster-dev.
Comment 3 Anand Avati 2013-07-31 12:14:03 EDT
REVIEW: http://review.gluster.org/5448 (Fix broken parallel install) posted (#1) for review on master by Tiziano Müller (tiziano.mueller@stepping-stone.ch)
Comment 4 Tiziano Müller 2013-07-31 12:18:16 EDT
I did the change against the master, but it applies to release-3.4 as well. Do I have to do this manually?
Comment 5 Anand Avati 2013-07-31 22:33:02 EDT
COMMIT: http://review.gluster.org/5448 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 16061c0d0f681117a53895d309e3a09b38f673e2
Author: Tiziano Müller <tiziano.mueller@stepping-stone.ch>
Date:   Wed Jul 31 18:04:29 2013 +0200

    Fix broken parallel install
    
    There is an automake bug when using _LTLIBRARIES, breaking parallel
    `make install` (see http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7328)
    
    Change-Id: I06aea1dc4c3e6cb0ae9aee5a04dd61881c8b6a7e
    BUG: 981888
    Signed-off-by: Tiziano Müller <tiziano.mueller@stepping-stone.ch>
    Reviewed-on: http://review.gluster.org/5448
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Kaushal 2013-07-31 22:59:15 EDT
(In reply to Tiziano Müller from comment #4)
> I did the change against the master, but it applies to release-3.4 as well.
> Do I have to do this manually?
Yes, you need to submit the patch for release-3.4 as well. Or someone else could do it on your behalf.

~kaushal
Comment 7 Niels de Vos 2013-08-01 10:09:42 EDT
(In reply to Tiziano Müller from comment #4)
> I did the change against the master, but it applies to release-3.4 as well.
> Do I have to do this manually?

The commands I would use to do this are like this:

$ cd glusterfs
$ git fetch -v --all
$ git checkout -t -b bug-981888_release-3.4 origin/release-3.4
$ git cherry-pick 16061c0d0f681117a53895d309e3a09b38f673e2
$ git commit --amend
  (make sure to remove the Change-Id so that a new one is generated and remove
   the Reviewed-on, Tested-by etc too.)
$ git log -1 -p
  (to verify the change)
$ ./rfc.sh
Comment 8 Anand Avati 2013-08-02 02:58:55 EDT
REVIEW: http://review.gluster.org/5468 (Fix broken parallel install) posted (#1) for review on release-3.4 by Tiziano Müller (tiziano.mueller@stepping-stone.ch)
Comment 9 Anand Avati 2013-08-02 09:45:10 EDT
COMMIT: http://review.gluster.org/5468 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit cd5f31de1d1b1668bed66de3ba83b64320712af8
Author: Tiziano Müller <tiziano.mueller@stepping-stone.ch>
Date:   Wed Jul 31 18:04:29 2013 +0200

    Fix broken parallel install
    
    There is an automake bug when using _LTLIBRARIES, breaking parallel
    `make install` (see http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7328)
    
    BUG: 981888
    Change-Id: Ib35ae47c048a45a881aeb9dbf8d41e09a4e766b9
    Signed-off-by: Tiziano Müller <tiziano.mueller@stepping-stone.ch>
    Reviewed-on: http://review.gluster.org/5468
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 10 Niels de Vos 2014-04-17 09:13:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.