Bug 981924 - [abrt] WARNING: at drivers/gpu/drm/i915/intel_display.c:3854 intel_modeset_check_state+0x5f9/0x600 [i915]()
[abrt] WARNING: at drivers/gpu/drm/i915/intel_display.c:3854 intel_modeset_ch...
Status: CLOSED DUPLICATE of bug 958295
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:540af4bc8448018cab9725c452b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 23:15 EDT by Brian J. Green
Modified: 2014-05-21 13:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-21 13:34:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (69.72 KB, text/plain)
2013-07-06 23:15 EDT, Brian J. Green
no flags Details

  None (edit)
Description Brian J. Green 2013-07-06 23:15:20 EDT
Additional info:
reporter:       libreport-2.1.5
WARNING: at drivers/gpu/drm/i915/intel_display.c:3854 intel_modeset_check_state+0x5f9/0x600 [i915]()
Hardware name: P5E-VM HDMI
wrong connector dpms state
Modules linked in: ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 bnep iptable_nat nf_nat_ipv4 nf_nat bluetooth rfkill iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables usblp iTCO_wdt iTCO_vendor_support lpc_ich mfd_core acpi_cpufreq mperf coretemp kvm_intel kvm i2c_i801 atl1 mii asus_atk0110 snd_hda_codec_hdmi snd_hda_codec_realtek microcode snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd soundcore uinput ata_generic pata_acpi i915 video i2c_algo_bit firewire_ohci drm_kms_helper firewire_core crc_itu_t drm pata_jmicron i2c_core usb_storage
Pid: 678, comm: Xorg Not tainted 3.9.8-300.fc19.x86_64 #1
Call Trace:
 [<ffffffffa00df700>] ? intel_modeset_check_state+0x5c0/0x600 [i915]
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ccbc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffffa00df739>] intel_modeset_check_state+0x5f9/0x600 [i915]
 [<ffffffffa00e2f29>] intel_crt_dpms+0x79/0xb0 [i915]
 [<ffffffffa00374a8>] drm_mode_obj_set_property_ioctl+0x308/0x320 [drm]
 [<ffffffffa00374f0>] drm_mode_connector_property_set_ioctl+0x30/0x40 [drm]
 [<ffffffffa00262c9>] drm_ioctl+0x4e9/0x5b0 [drm]
 [<ffffffffa00374c0>] ? drm_mode_obj_set_property_ioctl+0x320/0x320 [drm]
 [<ffffffff811ab495>] do_vfs_ioctl+0x305/0x520
 [<ffffffff8129495e>] ? file_has_perm+0x8e/0xa0
 [<ffffffff811ab731>] sys_ioctl+0x81/0xa0
 [<ffffffff8164efd9>] system_call_fastpath+0x16/0x1b

Potential duplicate: bug 895918
Comment 1 Brian J. Green 2013-07-06 23:15:27 EDT
Created attachment 769823 [details]
File: dmesg
Comment 2 Lukas Zachar 2013-07-11 15:08:11 EDT
Description of problem:
Booted after fresh install of 19 & following update.
IIRC similar kerneloops happend before the update ( after fresh install from DVD)

I have the VGA output set as only monitor.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.5
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.9-301.fc19.x86_64 root=/dev/mapper/main-root ro rd.md=0 rd.dm=0 rd.lvm.lv=main/swap vconsole.keymap=us rd.lvm.lv=main/root rd.luks.uuid=luks-4ef3ffd6-a1c3-4247-b35e-153d60941610 vconsole.font=latarcyrheb-sun16 rhgb quiet LANG=en_US.UTF-8
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at drivers/gpu/drm/i915/intel_display.c:3854 intel_modeset_check_state+0x5f9/0x600 [i915]()
Hardware name: Inspiron 1525                   
wrong connector dpms state
Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle bnep ip6t_REJECT bluetooth nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables snd_hda_codec_idt acpi_cpufreq snd_hda_codec_hdmi mperf snd_hda_intel coretemp uvcvideo kvm_intel snd_hda_codec videobuf2_vmalloc videobuf2_memops videobuf2_core videodev arc4 iwl3945 kvm snd_hwdep iwlegacy snd_seq iTCO_wdt iTCO_vendor_support mac80211 media sdhci_pci sdhci snd_seq_device dell_wmi mmc_core sparse_keymap snd_pcm cfg80211 dell_laptop joydev dcdbas microcode r592 rfkill memstick lpc_ich serio_raw sky2 mfd_core snd_page_alloc snd_timer snd soundcore i2c_i801 wmi uinput dm_crypt i915 i2c_algo_bit firewire_ohci drm_kms_helper firewire_core crc_itu_t drm i2c_core video
Pid: 710, comm: Xorg Not tainted 3.9.9-301.fc19.x86_64 #1
Call Trace:
 [<ffffffffa00ca700>] ? intel_modeset_check_state+0x5c0/0x600 [i915]
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ccbc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffffa00ca739>] intel_modeset_check_state+0x5f9/0x600 [i915]
 [<ffffffffa00cdf29>] intel_crt_dpms+0x79/0xb0 [i915]
 [<ffffffffa0030548>] drm_mode_obj_set_property_ioctl+0x308/0x320 [drm]
 [<ffffffffa0030590>] drm_mode_connector_property_set_ioctl+0x30/0x40 [drm]
 [<ffffffffa001f2c9>] drm_ioctl+0x4e9/0x5b0 [drm]
 [<ffffffffa0030560>] ? drm_mode_obj_set_property_ioctl+0x320/0x320 [drm]
 [<ffffffff81291139>] ? avc_has_perm_flags+0xc9/0x180
 [<ffffffff811ab495>] do_vfs_ioctl+0x305/0x520
 [<ffffffff8129495e>] ? file_has_perm+0x8e/0xa0
 [<ffffffff811ab731>] sys_ioctl+0x81/0xa0
 [<ffffffff8164f319>] system_call_fastpath+0x16/0x1b
Comment 3 Brian J. Green 2013-09-08 12:34:23 EDT
I'm actually not sure what the severity of this bug actually is.  Beyond filling up my abrt report daily, it doesn't seem to have an affect on the system.  I may be overlooking something though.
Comment 4 Adam Jackson 2014-05-21 13:34:15 EDT

*** This bug has been marked as a duplicate of bug 958295 ***

Note You need to log in before you can comment on or make changes to this bug.