Bug 981961 - [abrt] cinnamon-1.9.1-12.fc19: Gtk.py:416:__init__:RuntimeError: Gtk couldn't be initialized
[abrt] cinnamon-1.9.1-12.fc19: Gtk.py:416:__init__:RuntimeError: Gtk couldn't...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:c4edd5a908d0f0d888434693349...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 06:32 EDT by Subaena
Modified: 2015-02-17 10:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:55:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1017 bytes, text/plain)
2013-07-07 06:32 EDT, Subaena
no flags Details
File: core_backtrace (499 bytes, text/plain)
2013-07-07 06:32 EDT, Subaena
no flags Details
File: environ (2.24 KB, text/plain)
2013-07-07 06:32 EDT, Subaena
no flags Details

  None (edit)
Description Subaena 2013-07-07 06:32:38 EDT
Version-Release number of selected component:
cinnamon-1.9.1-12.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /bin/cinnamon-launcher
dso_list:       pygobject3-base-3.8.2-2.fc19.i686
executable:     /bin/cinnamon-launcher
kernel:         3.9.8-300.fc19.i686.PAE
runlevel:       N 5
uid:            0

Truncated backtrace:
Gtk.py:416:__init__:RuntimeError: Gtk couldn't be initialized

Traceback (most recent call last):
  File "/bin/cinnamon-launcher", line 36, in <module>
    if confirm_restart():
  File "/bin/cinnamon-launcher", line 13, in confirm_restart
    d = Gtk.MessageDialog(None, 0, Gtk.MessageType.WARNING, Gtk.ButtonsType.YES_NO)
  File "/usr/lib/python2.7/site-packages/gi/overrides/Gtk.py", line 519, in __init__
    **kwds)
  File "/usr/lib/python2.7/site-packages/gi/overrides/Gtk.py", line 446, in __init__
    Gtk.Dialog.__init__(self, **kwds)
  File "/usr/lib/python2.7/site-packages/gi/overrides/Gtk.py", line 416, in __init__
    raise RuntimeError("Gtk couldn't be initialized")
RuntimeError: Gtk couldn't be initialized

Local variables in innermost frame:
self: <MessageDialog object at 0xb730b5f4 (uninitialized at 0x0)>
type: <enum GTK_WINDOW_TOPLEVEL of type GtkWindowType>
kwds: {'buttons': <enum GTK_BUTTONS_YES_NO of type GtkButtonsType>, 'message_type': <enum GTK_MESSAGE_WARNING of type GtkMessageType>}
Comment 1 Subaena 2013-07-07 06:32:46 EDT
Created attachment 769932 [details]
File: backtrace
Comment 2 Subaena 2013-07-07 06:32:51 EDT
Created attachment 769933 [details]
File: core_backtrace
Comment 3 Subaena 2013-07-07 06:32:55 EDT
Created attachment 769934 [details]
File: environ
Comment 4 leigh scott 2013-07-07 08:17:33 EDT
You appear to have just run "yum install cinnamon" which doesn't install all required deps.

Run this to fix

yum install @Cinnamon
Comment 5 Fedora End Of Life 2015-01-09 13:43:59 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2015-02-17 10:55:47 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.