Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 981969 - crashes with "general protection fault" running el5-guest with qxl-vga
Summary: crashes with "general protection fault" running el5-guest with qxl-vga
Keywords:
Status: CLOSED DUPLICATE of bug 976789
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-07 11:36 UTC by Björn 'besser82' Esser
Modified: 2013-07-11 14:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-11 14:09:24 UTC
Type: Bug


Attachments (Terms of Use)
kernel.log with backtrace-output during crash (26.78 KB, text/x-log)
2013-07-07 11:36 UTC, Björn 'besser82' Esser
no flags Details
kernel.log duriring segfault/crash (44.90 KB, text/x-log)
2013-07-10 10:10 UTC, Björn 'besser82' Esser
no flags Details

Description Björn 'besser82' Esser 2013-07-07 11:36:35 UTC
Created attachment 769959 [details]
kernel.log with backtrace-output during crash

Description of problem:
  kernel crashes with "general protection fault" when using kvm-virtualization
  having an el6-guest and el5-guest running.


Version-Release number of selected component (if applicable):
  3.9.9-301.fc19.x86_64


How reproducible:
  I had a kvm-based VM with EL6 running and was launching another one for
  installing EL5.  Immediatly before the crash anaconda from el5 was detecting
  qxl-vga-adapter and _tried_ to start x-server for graphical install.
  Starting x-server in el5-vm failed and anaconda went to curses-fallback.
  A few seconds afterwards kernel on host crashed.


Steps to Reproduce:
  1. start an el6-guest with qxl-VGA
  2. create new el5-guest with qxl-VGA and start installation from iso
  3. kernel segfaults


Actual results:
  system freezes, after short time monitor switches to "text-mode" and shows
  detailed info about segfault / kernel panic

Expected results:
  system should stay `running and usable`

Additional info:
  abrt says something about `broken kernel (flags: GD)` on gpf #2,4 and 5

  Both vm's config is defaults from virt-manager, but 2 CPU, 2048 MB RAM,
  IDE1 is VirtIO with writeback-cache and qxl-based-VGA.

  Tried and reproduceable with CentOS 5.9 / 6.4 and/or SL 5.9 / 6.4
  guest-combos.

  Host Hardware is:
    Clevo P170HM-barebone
    Intel Core i7-2860QM CPU @ 2.50GHz
    32 GB RAM (4 x 8 GB / DDR3 - PC 1333)
    nvidia GTX560M (Clevo OEM) @ Gallium 0.4 on NVCF

  Kernel log is attached.

Comment 1 Björn 'besser82' Esser 2013-07-10 08:15:49 UTC
More infos ahead:

Description of problem:

  kernel crashes with "general protection fault" when using kvm-virtualization
  running / installing an el5-guest


Version-Release number of selected component (if applicable):

  kernel-3.9.9-301.fc19.x86_64
  ...
  kernel-3.9.5-301.fc19.x86_64

  with
  libvirt-1.0.5.2-1.fc19.x86_64
  qemu-kvm-1.4.2-4.fc19.x86_64
  xorg-x11-drv-nouveau-1.0.7-1.fc19.x86_64
  xorg-x11-server-Xorg-1.14.1-4.fc19.x86_64


How reproducible:
  100%


Steps to Reproduce:
  1. Create vm with default settings for el5 with install from iso
  2. Start vm
  3. Wait for anaconda detect VGA and start X-server
  4. Kernel segfaults causing crash / freeze


Additional info:
  There's no need to run any other vm.

Comment 2 Björn 'besser82' Esser 2013-07-10 10:10:43 UTC
Created attachment 771513 [details]
kernel.log duriring segfault/crash

Here's another log which exposes some cpu-lockup after kernel is segfaulting.

Additonal Info:

  The kernel segfaults when el5-kvm-guest uses qxl-vga, only.  Having the guest
  use cirrus-vga, e.g., everything seems to be fine.

Comment 3 Stephan Dühr 2013-07-10 11:38:17 UTC
I tried to reproduce this on my lenovo T420 which I use with nvidia disabled, so it uses Intel graphics. Also got a general protection fault.

abrt offered his help to report it, see
https://bugzilla.redhat.com/show_bug.cgi?id=983047

Comment 4 Stephan Dühr 2013-07-10 16:40:43 UTC
I tried kernel-3.9.9-302.fc19.x86_64 from
http://koji.fedoraproject.org/koji/buildinfo?buildID=431939
as recommended in 983047. No more crashes occured. In a CentOS 5.9 VM, X with qxl does not work, but that must be a different problem. In a CentOS 6.4 VM, X with qxl works for me.

Comment 5 Björn 'besser82' Esser 2013-07-11 14:09:24 UTC
(In reply to Stephan Dühr from comment #4)
> I tried kernel-3.9.9-302.fc19.x86_64 from as recommended in 983047.
> No more crashes occured.

Works on fresh F19-install for me, too.  On my previous install it didn't, but I think that was related to something other or I accidently fetched a wrong build.

So I'll close this, as it seems to be related, being a duplicate of bz #976789


> In a CentOS 5.9 VM, X with qxl does not work, but that must be a
> different problem. In a CentOS 6.4 VM, X with qxl works for me.

You need to install xorg-x11-drv-qxl manually and adapt /etc/X11/xorg.conf from "vesa" to "qxl".  spice-vdagent from EPEL-repo is needed for autoresizing, shared clipboard and other qxl-benefits, too.

*** This bug has been marked as a duplicate of bug 976789 ***


Note You need to log in before you can comment on or make changes to this bug.