Bug 982012 - 'glusterd.service' doesnt honor the value specified with '--prefix' used by 'configure'
'glusterd.service' doesnt honor the value specified with '--prefix' used by '...
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 14:01 EDT by John Smith
Modified: 2013-12-18 19:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 15:00:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Smith 2013-07-07 14:01:30 EDT
Description of problem:
When building from source and using systemd, the file glusterd.service has a hardcoded path instead of using the value specified with '--prefix' to './configure'.

Version-Release number of selected component (if applicable):
master

How reproducible:
Always

Steps to Reproduce:
git clone
./configure --prefix=/path/foo
make 
make install

Actual results:
glusterd.service looks for glusterd inb a hardcoded path

Expected results:
glusterd.service honors the --prefix value.
Comment 1 John Smith 2013-07-07 15:00:52 EDT
Already fixed in latest master, closing.

Note You need to log in before you can comment on or make changes to this bug.