Bug 982016 - [abrt] firewall-config-0.3.3-2.fc19: firewall-config:545:load_zones:TypeError: 'NoneType' object is not iterable
[abrt] firewall-config-0.3.3-2.fc19: firewall-config:545:load_zones:TypeError...
Status: CLOSED DUPLICATE of bug 1051735
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:866a38a789f318a805ff249e0e6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 15:19 EDT by bob53181
Modified: 2014-01-16 05:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-16 05:08:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (457 bytes, text/plain)
2013-07-07 15:19 EDT, bob53181
no flags Details
File: core_backtrace (172 bytes, text/plain)
2013-07-07 15:19 EDT, bob53181
no flags Details
File: environ (1.81 KB, text/plain)
2013-07-07 15:19 EDT, bob53181
no flags Details

  None (edit)
Description bob53181 2013-07-07 15:19:19 EDT
Version-Release number of selected component:
firewall-config-0.3.3-2.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.9.6-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
firewall-config:545:load_zones:TypeError: 'NoneType' object is not iterable

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 830, in onChangeView
    self.load_zones()
  File "/usr/bin/firewall-config", line 545, in load_zones
    zones = sorted(self.fw.getZones())
TypeError: 'NoneType' object is not iterable

Local variables in innermost frame:
zones: []
self: <__main__.FirewallConfig object at 0x2b79310>
active_zone: 'home'
Comment 1 bob53181 2013-07-07 15:19:23 EDT
Created attachment 770126 [details]
File: backtrace
Comment 2 bob53181 2013-07-07 15:19:26 EDT
Created attachment 770127 [details]
File: core_backtrace
Comment 3 bob53181 2013-07-07 15:19:29 EDT
Created attachment 770128 [details]
File: environ
Comment 4 Jiri Popelka 2013-07-08 06:22:48 EDT
No idea how FirewallClient.getZones() could have returned None.
It should return result of FirewallZone._zones.keys(), where _zones is dictionary. Dict's keys() could return [] but not None.
Comment 5 Jiri Popelka 2014-01-16 05:08:03 EST

*** This bug has been marked as a duplicate of bug 1051735 ***

Note You need to log in before you can comment on or make changes to this bug.