Bug 982021 - [abrt] xscreensaver-gl-extras-5.21-9.fc19: get_stencil_miptree: Process /usr/libexec/xscreensaver/stairs was killed by signal 11 (SIGSEGV)
[abrt] xscreensaver-gl-extras-5.21-9.fc19: get_stencil_miptree: Process /usr/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:fce99ae063b7db4b1530a98a90c...
:
: 982129 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 15:53 EDT by Karel Volný
Modified: 2013-07-11 20:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 20:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (43.44 KB, text/plain)
2013-07-07 15:53 EDT, Karel Volný
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-07 15:53 EDT, Karel Volný
no flags Details
File: core_backtrace (1.28 KB, text/plain)
2013-07-07 15:53 EDT, Karel Volný
no flags Details
File: dso_list (4.00 KB, text/plain)
2013-07-07 15:53 EDT, Karel Volný
no flags Details
File: environ (3.09 KB, text/plain)
2013-07-07 15:53 EDT, Karel Volný
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-07 15:53 EDT, Karel Volný
no flags Details
File: maps (19.75 KB, text/plain)
2013-07-07 15:53 EDT, Karel Volný
no flags Details
File: open_fds (187 bytes, text/plain)
2013-07-07 15:53 EDT, Karel Volný
no flags Details
File: proc_pid_status (937 bytes, text/plain)
2013-07-07 15:54 EDT, Karel Volný
no flags Details
File: var_log_messages (326 bytes, text/plain)
2013-07-07 15:54 EDT, Karel Volný
no flags Details

  None (edit)
Description Karel Volný 2013-07-07 15:53:18 EDT
Description of problem:
I've run xscreensaver from commandline in razorqt, and I just got the crash after returning back to the computer ...

there are tons of errors, last few lines:

xscreensaver-getimage-file: /usr/share/backgrounds/images: not a directory or URL
usage: xscreensaver-getimage-file [--verbose] directory
       Prints the name of a randomly-selected image file.  The directory
       is searched recursively.  Images smaller than 255x255 are excluded.

       The directory may also be the URL of an RSS/Atom feed.  Enclosed
       images will be downloaded and cached locally.

xscreensaver:   signal: 0: child pid 25429 (polyhedra) terminated with signal 11.
xscreensaver:   signal: 0: child pid 25484 (gltext) terminated with signal 11.
xscreensaver:   signal: 0: child pid 25526 (spheremonics) terminated with signal 11.
xscreensaver:   signal: 0: child pid 25608 (flipflop) terminated with signal 11.
penetrate: could not load font -*-courier-*-r-*-*-*-380-*-*-*-*-*-*.
xscreensaver-getimage-file: /usr/share/backgrounds/images: not a directory or URL
usage: xscreensaver-getimage-file [--verbose] directory
       Prints the name of a randomly-selected image file.  The directory
       is searched recursively.  Images smaller than 255x255 are excluded.

       The directory may also be the URL of an RSS/Atom feed.  Enclosed
       images will be downloaded and cached locally.

xscreensaver:   signal: 0: child pid 25680 (mirrorblob) terminated with signal 11.
xscreensaver-getimage-file: /usr/share/backgrounds/images: not a directory or URL
usage: xscreensaver-getimage-file [--verbose] directory
       Prints the name of a randomly-selected image file.  The directory
       is searched recursively.  Images smaller than 255x255 are excluded.

       The directory may also be the URL of an RSS/Atom feed.  Enclosed
       images will be downloaded and cached locally.

xscreensaver:   signal: 0: child pid 25739 (carousel) terminated with signal 11.
xscreensaver:   signal: 0: child pid 25783 (cubestorm) terminated with signal 11.
xscreensaver:   signal: 0: child pid 25824 (dangerball) terminated with signal 11.
xscreensaver-getimage-file: /usr/share/backgrounds/images: not a directory or URL
usage: xscreensaver-getimage-file [--verbose] directory
       Prints the name of a randomly-selected image file.  The directory
       is searched recursively.  Images smaller than 255x255 are excluded.

       The directory may also be the URL of an RSS/Atom feed.  Enclosed
       images will be downloaded and cached locally.

xscreensaver:   signal: 0: child pid 26678 (carousel) terminated with signal 11.
xscreensaver:   signal: 0: child pid 26767 (hilbert) terminated with signal 11.
xscreensaver: 21:37:28: authentication via PAM cancelled.
xscreensaver: 21:37:29: authentication via PAM cancelled.

Version-Release number of selected component:
xscreensaver-gl-extras-5.21-9.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        stairs -root
crash_function: get_stencil_miptree
executable:     /usr/libexec/xscreensaver/stairs
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 get_stencil_miptree at brw_misc_state.c:327
 #1 brw_workaround_depthstencil_alignment at brw_misc_state.c:344
 #2 brw_try_draw_prims at brw_draw.c:388
 #3 brw_draw_prims at brw_draw.c:531
 #4 vbo_exec_vtx_flush at ../../../src/mesa/vbo/vbo_exec_draw.c:399
 #5 vbo_exec_FlushVertices_internal at ../../../src/mesa/vbo/vbo_exec_api.c:555
 #6 vbo_exec_FlushVertices at ../../../src/mesa/vbo/vbo_exec_api.c:1164
 #7 _mesa_Translatef at ../../../src/mesa/main/matrix.c:446
 #8 draw_stairs_internal at ../../../hacks/glx/stairs.c:238
 #9 draw_stairs at ../../../hacks/glx/stairs.c:553
Comment 1 Karel Volný 2013-07-07 15:53:24 EDT
Created attachment 770141 [details]
File: backtrace
Comment 2 Karel Volný 2013-07-07 15:53:27 EDT
Created attachment 770142 [details]
File: cgroup
Comment 3 Karel Volný 2013-07-07 15:53:32 EDT
Created attachment 770143 [details]
File: core_backtrace
Comment 4 Karel Volný 2013-07-07 15:53:39 EDT
Created attachment 770144 [details]
File: dso_list
Comment 5 Karel Volný 2013-07-07 15:53:44 EDT
Created attachment 770145 [details]
File: environ
Comment 6 Karel Volný 2013-07-07 15:53:49 EDT
Created attachment 770146 [details]
File: limits
Comment 7 Karel Volný 2013-07-07 15:53:53 EDT
Created attachment 770147 [details]
File: maps
Comment 8 Karel Volný 2013-07-07 15:53:59 EDT
Created attachment 770148 [details]
File: open_fds
Comment 9 Karel Volný 2013-07-07 15:54:03 EDT
Created attachment 770149 [details]
File: proc_pid_status
Comment 10 Karel Volný 2013-07-07 15:54:06 EDT
Created attachment 770150 [details]
File: var_log_messages
Comment 11 Karel Volný 2013-07-07 17:03:53 EDT
I guess this is the same like I reported just a while ago ... will abrt find the duplicate or am I wrong?
- I've just left xscreensaver running for a while ...

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        hypertorus -root
crash_function: get_stencil_miptree
executable:     /usr/libexec/xscreensaver/hypertorus
kernel:         3.9.8-300.fc19.x86_64
package:        xscreensaver-gl-extras-5.21-9.fc19
reason:         Process /usr/libexec/xscreensaver/hypertorus was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:
Comment 12 Mamoru TASAKA 2013-07-07 20:01:46 EDT
Would you try upgrading libXi (perhaps)? I saw this issue from around 2013-07-02 upgrade and now I don't see this from around 2013-07-06 upgrade.

Anyway not xscreensaver issue. Once asking mesa maintainer for help.
Comment 13 Mamoru TASAKA 2013-07-08 05:06:06 EDT
*** Bug 982129 has been marked as a duplicate of this bug. ***
Comment 14 Karel Volný 2013-07-08 05:20:52 EDT
another in series of xscreensaver crashes

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        hilbert -root
crash_function: get_stencil_miptree
executable:     /usr/libexec/xscreensaver/hilbert
kernel:         3.9.8-300.fc19.x86_64
package:        xscreensaver-gl-extras-5.21-9.fc19
reason:         Process /usr/libexec/xscreensaver/hilbert was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:
Comment 15 Karel Volný 2013-07-08 05:40:25 EDT
another in series of xscreensaver crashes

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        flipscreen3d -root
crash_function: get_stencil_miptree
executable:     /usr/libexec/xscreensaver/flipscreen3d
kernel:         3.9.8-300.fc19.x86_64
package:        xscreensaver-gl-extras-5.21-9.fc19
reason:         Process /usr/libexec/xscreensaver/flipscreen3d was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:
Comment 16 Karel Volný 2013-07-08 05:51:52 EDT
another in series of xscreensaver crashes

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        stonerview -root
crash_function: get_stencil_miptree
executable:     /usr/libexec/xscreensaver/stonerview
kernel:         3.9.8-300.fc19.x86_64
package:        xscreensaver-gl-extras-5.21-9.fc19
reason:         Process /usr/libexec/xscreensaver/stonerview was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:
Comment 17 Karel Volný 2013-07-08 06:59:09 EDT
this crashes faster than I'm able to report, wandering what will be detected as duplicate :-)

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        skytentacles -root
crash_function: get_stencil_miptree
executable:     /usr/libexec/xscreensaver/skytentacles
kernel:         3.9.8-300.fc19.x86_64
package:        xscreensaver-gl-extras-5.21-9.fc19
reason:         Process /usr/libexec/xscreensaver/skytentacles was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:
Comment 18 Karel Volný 2013-07-08 07:37:17 EDT
(In reply to Mamoru TASAKA from comment #12)
> Would you try upgrading libXi (perhaps)?

ok, I've just upgraded to libXi-1.7.2-1.fc19.x86_64 ... not sure if I have to restart X, will do that later
Comment 19 Karel Volný 2013-07-11 08:55:57 EDT
(In reply to Karel Volný from comment #18)
> (In reply to Mamoru TASAKA from comment #12)
> > Would you try upgrading libXi (perhaps)?
> 
> ok, I've just upgraded to libXi-1.7.2-1.fc19.x86_64 ... not sure if I have
> to restart X, will do that later

no crashes since the upgrade ... could we conclude this fixes the issue?
Comment 20 Mamoru TASAKA 2013-07-11 20:20:21 EDT
I *guess* so (because I also saw the similar issue: all GL application crashed, and *perhaps* libXi upgrade fixed this).

Once closing this (as at least currently you don't see this issue). Anyway feel free to open new ticket when you see another issue.

Note You need to log in before you can comment on or make changes to this bug.