Bug 982061 - virt-viewer cannot change to fullscreen mode by "F11" or menu "Full screen"
virt-viewer cannot change to fullscreen mode by "F11" or menu "Full screen"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 23:37 EDT by CongDong
Modified: 2015-05-11 18:16 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 12:36:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer log (7.76 KB, text/plain)
2013-07-07 23:37 EDT, CongDong
no flags Details

  None (edit)
Description CongDong 2013-07-07 23:37:28 EDT
Created attachment 770246 [details]
virt-viewer log

Description of problem:
Use virt-viewer connect a guest with more than one display, and type "F11" or "View" menu-> "Full screen", then the guest cannot change to fullscreen mode, just only one window can change to fullscreen

Version-Release number of selected component (if applicable):
# rpm -qa virt-viewer
virt-viewer-0.5.6-3.el6.x86_64
# rpm -qa | grep spice
spice-gtk-0.20-1.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-glib-0.20-1.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64
spice-server-0.12.3-1.el6.x86_64
spice-gtk-python-0.20-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a guest with 2 or more displays

2.Use virt-viewer to connect it:
# virt-viewer guest

3.In one of the windows, click "View" -> "Full screen" or can type "F11"

Actual results:
Just one window is fullscreen, the other didn't change.

Expected results:
All windows should change to full screen mode and can extend to every display.

Additional info:
Comment 2 CongDong 2013-07-08 00:51:59 EDT
This bug cannot reproduce with previous version virt-viewer, so Add "Regression"
Comment 4 CongDong 2013-07-08 03:09:06 EDT
Can't reproduce with virt-viewer-0.5.2-18.el6.x86_64
Comment 5 Christophe Fergeau 2013-07-08 11:54:48 EDT
This is an intentional change in virt-viewer 0.5.6, see https://bugzilla.redhat.com/show_bug.cgi?id=558241#c29
Comment 6 Marc-Andre Lureau 2013-07-08 12:36:27 EDT
closing for now, as this is intended change

Note You need to log in before you can comment on or make changes to this bug.