Bug 982078 - Some options need their op-version bumped down
Some options need their op-version bumped down
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Sachidananda Urs
glusterd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 02:03 EDT by Kaushal
Modified: 2015-12-24 04:29 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta4_1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 04:29:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushal 2013-07-08 02:03:32 EDT
Description of problem:
Downstream rhs-2.0 branch contains features that are only present in upstream release-3.4 branch. The downstream rhs-2.1 branch was branched off from upstream master, so some options have a higher op-version even though they were already present in rhs-2.0, and need to bumped down. The specific options are,

cluster.readdir-failover
cluster.readdir-optimize
cluster.stripe-coalesce
cluster.subvols-per-directory
GLUSTERD_QUORUM_RATIO_KEY
GLUSTERD_QUORUM_TYPE_KEY
performance.enable-least-priority
performance.strict-o-direct
performance.strict-write-ordering
server.root-squash
storage.linux-aio
storage.owner-gid
storage.owner-uid
Comment 2 Kaushal 2013-07-08 04:42:51 EDT
On review at https://code.engineering.redhat.com/gerrit/9824
Comment 3 Amar Tumballi 2013-07-08 04:44:27 EDT
critical for compatibility with older clients.
Comment 4 Kaushal 2013-07-11 03:37:52 EDT
Change merged as commit 820d1b728 "glusterd: Bump down op-version for some options"
Comment 5 Sachidananda Urs 2013-08-07 01:39:14 EDT
Kaushal, please provide me steps on how to verify these.
Comment 6 Kaushal 2013-08-07 03:09:29 EDT
You should be able to set the listed options in hybrid cluster of rhs-2.0 and rhs-2.1. Without the fix, you wouldn't be able to set these options as rhs-2.1 would think these options were not present in rhs-2.1.
Comment 7 Sachidananda Urs 2013-08-13 05:07:28 EDT
Kaushal as per our discussions with DEV, hybrid cluster having rhs-2.0 and rhs-2.1 is not supported. So, this bug will be deferred.
Comment 9 Atin Mukherjee 2015-12-24 04:29:36 EST
Its not a valid bug since we don't support heterogeneous cluster. Hence closing it.

Note You need to log in before you can comment on or make changes to this bug.