Bug 982098 - [abrt] gnome-abrt-0.2.12-3.fc19: module.py:103:get_interfaces_for_object:RuntimeError: sys.path must be a list of directory names
[abrt] gnome-abrt-0.2.12-3.fc19: module.py:103:get_interfaces_for_object:Runt...
Status: CLOSED DUPLICATE of bug 952840
Product: Fedora
Classification: Fedora
Component: gnome-abrt (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
abrt_hash:ba683d5397372ec9601fb9d0e97...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 03:06 EDT by spital
Modified: 2016-11-30 19:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 03:21:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.30 KB, text/plain)
2013-07-08 03:06 EDT, spital
no flags Details
File: core_backtrace (632 bytes, text/plain)
2013-07-08 03:06 EDT, spital
no flags Details
File: environ (3.34 KB, text/plain)
2013-07-08 03:06 EDT, spital
no flags Details

  None (edit)
Description spital 2013-07-08 03:06:37 EDT
Description of problem:
dunno

Version-Release number of selected component:
gnome-abrt-0.2.12-3.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        python /usr/bin/gnome-abrt
dso_list:       pygobject3-base-3.8.2-2.fc19.x86_64
executable:     /usr/bin/gnome-abrt
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
module.py:103:get_interfaces_for_object:RuntimeError: sys.path must be a list of directory names

Traceback (most recent call last):
  File "/usr/bin/gnome-abrt", line 29, in <module>
    from gi.repository import Gtk
  File "/usr/lib64/python2.7/site-packages/gi/importer.py", line 68, in load_module
    dynamic_module._load()
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 291, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "/usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py", line 67, in <module>
    class Widget(Gtk.Widget):
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 177, in __getattr__
    interfaces = tuple(interface for interface in get_interfaces_for_object(info)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 103, in get_interfaces_for_object
    module = __import__('gi.repository.%s' % namespace, fromlist=[name])
RuntimeError: sys.path must be a list of directory names

Local variables in innermost frame:
name: 'Buildable'
object_info: <ObjectInfo object (Widget) at 0x0xc51a70>
interfaces: [<class 'gi.repository.Atk.ImplementorIface'>]
namespace: 'Gtk'
module: <gi.module.DynamicModule 'Atk' from '/usr/lib64/girepository-1.0/Atk-1.0.typelib'>
interface_info: <InterfaceInfo object (Buildable) at 0x0xd6bab8>
Comment 1 spital 2013-07-08 03:06:41 EDT
Created attachment 770307 [details]
File: backtrace
Comment 2 spital 2013-07-08 03:06:44 EDT
Created attachment 770308 [details]
File: core_backtrace
Comment 3 spital 2013-07-08 03:06:47 EDT
Created attachment 770309 [details]
File: environ
Comment 4 Jakub Filak 2013-07-08 03:21:10 EDT

*** This bug has been marked as a duplicate of bug 952840 ***

Note You need to log in before you can comment on or make changes to this bug.