Bug 982132 - cli - user update, no validation of --disabled parameter
cli - user update, no validation of --disabled parameter
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 04:30 EDT by Ales Dujicek
Modified: 2014-08-14 08:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-14 08:47:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-07-08 04:30:17 EDT
Description of problem:

if you set wrong parameter to 'user update --disabled ' command
then --disabled defaults to False and you get no warning

note these scenarios:

user update --username alice --disabled True
-> False

user update --username alice --disabled Foo
-> False

user update --username alice --disabled ""
-> None

Version-Release number of selected component (if applicable):
katello-certs-tools-1.4.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.107.43fee0b.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.825.a0f965d.el6.noarch
katello-glue-pulp-1.4.2-1.git.825.a0f965d.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.825.a0f965d.el6.noarch
katello-1.4.2-1.git.825.a0f965d.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.107.43fee0b.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-common-1.4.2-1.git.825.a0f965d.el6.noarch
katello-all-1.4.2-1.git.825.a0f965d.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch

How reproducible:
always

Steps to Reproduce:
1. user create --username alice --password testing --email root@localhost
2. user update --username alice --disabled True
3. user info --username alice
Comment 1 RHEL Product and Program Management 2013-09-17 00:24:00 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Bryan Kearney 2014-08-14 08:47:20 EDT
This is related to the old cli, I am closing this out. If you feel this was a mistake, please go ahead and re-open. Thank you!

Note You need to log in before you can comment on or make changes to this bug.