Bug 982149 - [whql][netkvm]win2012 bsod(7E) when running HCK job "NDISTest 6.0 - [1 Machine] - 1c_Mini6Send" on ovs
[whql][netkvm]win2012 bsod(7E) when running HCK job "NDISTest 6.0 - [1 Machin...
Status: CLOSED DUPLICATE of bug 977708
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 05:16 EDT by lijin
Modified: 2013-08-23 00:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 02:43:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lijin 2013-07-08 05:16:28 EDT
Description of problem:
guest win2012 bsod(7E) when running HCK job "NDISTest 6.0 - [1 Machine] - 1c_Mini6Send"  on ovs

Version-Release number of selected component (if applicable):
openvswitch-1.9.0-3.el6.x86_64
virtio-win-1.6.5-5
kernel-2.6.32-393.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.377.el6.x86_64
seabios-0.6.1.2-27.el6.x86_64
vgabios-0.6b-3.7.el6.noarch

How reproducible:
80%

Steps to Reproduce:
1.boot two win2012 guest:
nic1:
N_REPEAT=1 ;
while true;
do date;
sleep 2;
echo "test round: $N_REPEAT" ;
N_REPEAT=$(($N_REPEAT+1)) &&
/usr/libexec/qemu-kvm \
-m 6G \
-smp 8,cores=8 \
-cpu cpu64-rhel6,+x2apic,+sep \
-usb \
-device usb-tablet \
-drive file=win2012-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 \
-netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/ovs0-ifup,downscript=/etc/ovs0-ifdown \
-device virtio-net-pci,netdev=hostnet0,mac=00:52:40:14:23:23,bus=pci.0,addr=0x4,id=virtio-net-pci0 \
-netdev tap,sndbuf=0,id=hostnet2,script=/etc/ovs1-ifup,downscript=/etc/ovs1-ifdown \
-device e1000,netdev=hostnet2,mac=02:21:54:14:31:10,bus=pci.0,addr=0x6 \
-uuid 4d614d05-84aa-4bda-97ac-1c155cd29b87 \
-no-kvm-pit-reinjection \
-chardev socket,id=111a,path=/tmp/monitor-win2012-65-nic1,server,nowait \
-mon chardev=111a,mode=readline \
-vnc :1 \
-vga cirrus \
-name win2012-nic1-65-HCK \
-rtc base=localtime,clock=host,driftfix=slew \
-global PIIX4_PM.disable_s3=0 \
-global PIIX4_PM.disable_s4=0 \
-monitor stdio
done

nic2:
N_REPEAT=1 ;
while true;
do date;
sleep 2;
echo "test round: $N_REPEAT" ;
N_REPEAT=$(($N_REPEAT+1)) &&
/usr/libexec/qemu-kvm \
-m 4G \
-smp 2,cores=2 \
-cpu cpu64-rhel6,+x2apic,+sep \
-usb \
-device usb-tablet \
-drive file=win2012-nic2.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 \
-netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/ovs0-ifup,downscript=/etc/ovs0-ifdown \
-device virtio-net-pci,netdev=hostnet0,mac=00:14:20:14:11:42,bus=pci.0,addr=0x4,id=virtio-net-pci0 \
-netdev tap,sndbuf=0,id=hostnet2,script=/etc/ovs1-ifup,downscript=/etc/ovs1-ifdown \
-device e1000,netdev=hostnet2,mac=00:20:20:24:10:20,bus=pci.0,addr=0x6 \
-uuid ca548449-8a31-43c4-b195-303deec14a68 \
-no-kvm-pit-reinjection \
-chardev socket,id=111a,path=/tmp/monitor-win2012-65-nic2,server,nowait \
-mon chardev=111a,mode=readline \
-vnc :2 \
-vga cirrus \
-name win2012-nic2-65-HCK \
-rtc base=localtime,clock=host,driftfix=slew \
-global PIIX4_PM.disable_s3=0 \
-global PIIX4_PM.disable_s4=0 \
-monitor stdio
done

2.run job  job "NDISTest 6.0 - [1 Machine] - 1c_Mini6Send" in HCK

Actual results:
guest bsod with 7E code

Expected results:
job can pass,no bsod

Additional info:
I will upload the dump file later
Comment 1 lijin 2013-07-08 05:23:26 EDT
windbg info:
3: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (7e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arguments:
Arg1: ffffffff80000003, The exception code that was not handled
Arg2: fffff8800631318d, The address that the exception occurred at
Arg3: fffff880052bca08, Exception Record Address
Arg4: fffff880052bc240, Context Record Address

Debugging Details:
------------------


EXCEPTION_CODE: (HRESULT) 0x80000003 (2147483651) - One or more arguments are invalid

FAULTING_IP: 
ndprot630+9118d
fffff880`0631318d cc              int     3

EXCEPTION_RECORD:  fffff880052bca08 -- (.exr 0xfffff880052bca08)
ExceptionAddress: fffff8800631318d (ndprot630+0x000000000009118d)
   ExceptionCode: 80000003 (Break instruction exception)
  ExceptionFlags: 00000000
NumberParameters: 1
   Parameter[0]: 0000000000000000

CONTEXT:  fffff880052bc240 -- (.cxr 0xfffff880052bc240)
rax=0000000000000001 rbx=fffffa800b961800 rcx=fffffa80050af4b0
rdx=0000000000000000 rsi=fffffa80050e49b8 rdi=fffff88002cdaf40
rip=fffff8800631318d rsp=fffff880052bcc40 rbp=fffff880052bccf0
 r8=ffffffffffffffff  r9=8101010101010100 r10=78f8f8f8f8f900e0
r11=fffffa80050a2030 r12=fffff80184072000 r13=000000068fd9dfad
r14=fffff8800632b420 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00000286
ndprot630+0x9118d:
fffff880`0631318d cc              int     3
Resetting default scope

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

BUGCHECK_STR:  AV

PROCESS_NAME:  System

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0x80000003 - {EXCEPTION}  Breakpoint  A breakpoint has been reached.

EXCEPTION_PARAMETER1:  0000000000000000

LAST_CONTROL_TRANSFER:  from fffff8800632b477 to fffff8800631318d

STACK_TEXT:  
fffff880`052bcc40 fffff880`0632b477 : fffffa80`050e4988 000006bd`00000000 fffff901`0020a1b8 00000b38`00000001 : ndprot630+0x9118d
fffff880`052bcd00 fffff801`84094535 : fffffa80`050e49b8 fffff801`841234d2 00000000`0000000f 00000000`00070166 : ndprot630+0xa9477
fffff880`052bcd50 fffff801`840d2e16 : fffff880`02ccf180 fffffa80`0b961800 fffff880`02cdaf40 fffffa80`04e94040 : nt!PspSystemThreadStartup+0x59
fffff880`052bcda0 00000000`00000000 : fffff880`052bd000 fffff880`052b7000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16


FOLLOWUP_IP: 
ndprot630+9118d
fffff880`0631318d cc              int     3

SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  ndprot630+9118d

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ndprot630

IMAGE_NAME:  ndprot630.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  5049c61b

STACK_COMMAND:  .cxr 0xfffff880052bc240 ; kb

FAILURE_BUCKET_ID:  AV_ndprot630+9118d

BUCKET_ID:  AV_ndprot630+9118d

Followup: MachineOwner
---------
Comment 4 Dmitry Fleytman 2013-08-20 02:43:04 EDT

*** This bug has been marked as a duplicate of bug 977708 ***
Comment 5 guo jiang 2013-08-23 00:46:49 EDT
Verified this issue on virtio-win-prewhql-66.

Package version:
  openvswitch-1.9.0-3.el6.x86_64
  virtio-win-prewhql-66
  kernel-2.6.32-413.el6.x86_64
  qemu-kvm-rhev-0.12.1.2-2.397.el6.x86_64
  seabios-0.6.1.2-28.el6.x86_64
  vgabios-0.6b-3.7.el6.noarch

Actua  Result:
on build-66: HCK job "NDISTest 6.0 - [1 Machine] - 1c_Mini6Send" could pass without any error.

Based on above, this issue has been fixed already.

Note You need to log in before you can comment on or make changes to this bug.