Bug 982232 - performance page takes >1sec to load (on first load)
performance page takes >1sec to load (on first load)
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.2
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.3
Assigned To: Ryan Barry
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 08:32 EDT by Fabian Deutsch
Modified: 2014-02-17 13:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-17 13:29:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-07-08 08:32:10 EDT
Description of problem:
Loading the performances page can take up to 1 second (or more) on the first page load.
This can be due to the call to get_available_profiles() which is then calling an external binary. That call took 1sec on my sysytem.

Maybe we can cache this information e.g. build it once when the app loads or on the first page load.

Note You need to log in before you can comment on or make changes to this bug.