Bug 982269 - value for 'mode' column when deploying multiple storage node is not 'NORMAL' for all the storage nodes
value for 'mode' column when deploying multiple storage node is not 'NORMAL' ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity low
: ER01
: JON 3.2.0
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 10:18 EDT by Varun Khurana
Modified: 2014-01-02 15:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:34:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Varun Khurana 2013-07-08 10:18:11 EDT
Description of problem:
value for 'mode' column when deploying multiple storage node is not 'NORMAL' for all the storage nodes. It should be 'NORMAL' for every storage node installed. 


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Install RHQ server, agent and Storage node on IP1 machine.
2. Create rhq-storage.properties file with seeds= 'IP1 address' in user's home directory on IP2 machine.
3. Install RHQ storage node using the following command on IP2 machine.

rhqctl install --storage --storage-config=/home/${user}/rhq-storage.properties

4. Run http://IP1:7080/coregui/ on IP2 machine
5. Click on Administratiion tab and selct Storage Nodes from under Topology.


Actual results:

You should see two storage nodes and the value of 'Mode' column is 'Normal' for one storage node and 'Installed' for the other storage node.


Expected results:
It should be 'NORMAL' for both the storage nodes


Additional info:
Comment 1 Varun Khurana 2013-07-08 10:33:44 EDT
4th comment should be Run  http://IP1:7080/coregui/
Comment 2 John Sanda 2013-08-26 11:15:11 EDT
The design and implementation has gone through substantial revisions since this bug was opened. See https://docs.jboss.org/author/display/RHQ/Deploying+Storage+Nodes for details. In short, the mode will change. There is a now a "Cluster Status" column that reports on the status as well. From that it can more easily be determined whether the node is joining/leaving the cluster or if it is down for some reason. The mode tells you the exact state of the nodes. It is a many-to-one relationship between the mode and cluster status. This is covered in detail in the design doc.
Comment 3 Armine Hovsepyan 2013-08-26 11:36:17 EDT
verified.
No need to testing - done in scope of other tests. Now the modes are different from maintenance->normal.

thank you.

Note You need to log in before you can comment on or make changes to this bug.