Bug 982275 - gluster creates separate mountpoint for samba by default when samba is not installed
gluster creates separate mountpoint for samba by default when samba is not in...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Linux
high Severity high
: ---
: ---
Assigned To: Raghavendra Talur
surabhi
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 10:43 EDT by Martin Bukatovic
Modified: 2013-09-23 18:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Bukatovic 2013-07-08 10:43:38 EDT
Description of problem
======================

By default, GlusterFS automatically creates separate samba mountpoint for any volume even though samba is not (and was not) installed.

Version-Release number of selected component (if applicable)
============================================================

# rpm -qa | grep gluster
org.apache.hadoop.fs.glusterfs-glusterfs-0.20.2_0.2-1.noarch
glusterfs-3.3.0.7rhs-1.el6rhs.x86_64
glusterfs-server-3.3.0.7rhs-1.el6rhs.x86_64
glusterfs-fuse-3.3.0.7rhs-1.el6rhs.x86_64

How reproducible
================

always

Steps to Reproduce
==================

1. create new gluster volume, eg:

gluster volume create test-volume replica 2 transport tcp \
  dhcp-37-113.lab.eng.brq.redhat.com:/export/brick1/test-brick/ \ 
  dhcp-37-118.lab.eng.brq.redhat.com:/export/brick1/test-brick/

2. start the volume:

gluster volume start test-volume 

3. mount the volume:

mount -t glusterfs dhcp-37-113.lab.eng.brq.redhat.com:/test-volume /mnt/test-volume

Actual results
==============

GlusterFS mount the volume twice:

mount | grep fuse.glusterfs
dhcp-37-123.lab.eng.brq.redhat.com:/hadoop-volume on /mnt/samba/hadoop-volume type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)
dhcp-37-113.lab.eng.brq.redhat.com:/hadoop-volume on /mnt/hadoop-volume type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)

Also new line in /etc/fstab was created:

# tail -1 /etc/fstab 
dhcp-37-123.lab.eng.brq.redhat.com:/hadoop-volume /mnt/samba/hadoop-volume glusterfs defaults,transport=tcp 0 0

Expected results
================

Gluster mounts the volume just once without editing fstab:

mount | grep fuse.glusterfs
dhcp-37-113.lab.eng.brq.redhat.com:/hadoop-volume on /mnt/hadoop-volume type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)

Additional info
===============

I installed gluster recently on new virtual machine, so current version of gluster was installed directly without update and no samba was installed in the past.

I seems it is caused by the samba hook: /var/lib/glusterd/hooks/1/start/post/S30samba-start.sh

This BZ is related to previous one: 863907
Comment 1 Martin Bukatovic 2013-07-08 10:53:08 EDT
Correction: I accidentally left outputs from previous volume with different name in 'Actual results' and 'Expected results' sections (since I tried it multiple times), but the only thing which differs is the volume name.
Comment 5 Vivek Agarwal 2013-07-22 20:23:01 EDT
Can we try this with latest Big bend binaries? This seems to have been tried with Anshi binaries?
Comment 7 Scott Haines 2013-07-23 04:37:23 EDT
Per 07/23 BLR bug council, removing blocker? flag as it is only happening in 3.3. Awaiting update testing against 3.4.
Comment 9 Martin Bukatovic 2013-07-24 11:43:48 EDT
(In reply to Scott Haines from comment #7)
> Per 07/23 BLR bug council, removing blocker? flag as it is only happening in
> 3.3. Awaiting update testing against 3.4.

Rechecked with gluster 3.4 from brew:

glusterfs-3.4.0.12rhs.beta6-1.el6rhs
glusterfs-server-3.4.0.12rhs.beta6-1
glusterfs-fuse-3.4.0.12rhs.beta6-1

This version works correctly: /mnt/samba/test-volume is not mounted and fstab file is not changed.
Comment 11 surabhi 2013-08-13 08:15:40 EDT
This bug does not apply for BigBend as glusterfs no longer uses mount point and fstab entry for samba.
Moving it to verified state.
Comment 12 Scott Haines 2013-09-23 18:29:54 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.