Bug 98230 - Bad: kudzu hangs lacie usb drive connected on reboot
Bad: kudzu hangs lacie usb drive connected on reboot
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-28 11:21 EDT by caveman_pexy
Modified: 2014-03-16 22:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 23:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description caveman_pexy 2003-06-28 11:21:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Good: On kernel revs before kernel-2.4.20-13.9 - no problem.

Bad: With kernel-2.4.20-13.9 and kernel-2.4.20-18.9 the system
hangs on booting when it reaches "kudzu" and the "Lacie"
USB Drive is connected. The only remedy is to reboot....

Bypassing "kudzu" on boot via 
interactive booting - the system boots up.
BUT then running a manual "kudzu" at the command prompt the
program will freeze-up again. The same happens when running a
"ls -lR" command.

Leaving the USB Drive disconnected - the system boots normal.
BUT again - on connecting the USB drive after boot - a manual
running of "kudzu" will hang. The "kudzu" process will not 
respond to a "Control-C" or "kill -9" and seems to stop without any 
messages after a looooong while after exiting the X window. 

The only "not-normal" entries in log/messages:

Jun 21 01:35:47 mac_hine kernel: scsi: device set offline - not ready or command
retry failed after bus reset: host 0 channel 0 id 0 lun 0
Jun 21 01:35:47 mac_hine kernel: USB Mass Storage support registered.
Jun 21 01:35:47 mac_hine kernel: usb-uhci.c: ENXIO 80000380, flags 0, urb
df541bc0, burb df541940
Jun 21 01:35:47 mac_hine kernel: usb.c: error getting string descriptor 0 (error=-6)
Jun 21 01:35:47 mac_hine kernel: usb-uhci.c: ENXIO 80000380, flags 0, urb
df541bc0, burb df541940
Jun 21 01:35:47 mac_hine kernel: usb.c: error getting string descriptor 0 (error=-6)
Jun 21 01:35:47 mac_hine kernel: usb-uhci.c: ENXIO 80000380, flags 0, urb
df541bc0, burb df541940
Jun 21 01:35:47 mac_hine kernel: usb.c: error getting string descriptor 0 (error=-6)
Jun 21 01:35:47 mac_hine kernel: usb-uhci.c: ENXIO 80000380, flags 0, urb
df541bc0, burb df541940
Jun 21 01:35:47 mac_hine kernel: usb.c: error getting string descriptor 0 (error=-6)
Jun 21 01:35:47 mac_hine kernel: usb-uhci.c: ENXIO 80000380, flags 0, urb
df541bc0, burb df541940
Jun 21 01:35:47 mac_hine kernel: usb.c: error getting string descriptor 0 (error=-6)
Jun 21 01:35:47 mac_hine kernel: usb-uhci.c: ENXIO 80000380, flags 0, urb
df541bc0, burb df541940
Jun 21 01:35:47 mac_hine kernel: usb.c: error getting string descriptor 0 (error=-6)
Jun 21 01:35:47 mac_hine kernel: usb-uhci.c: ENXIO 80000380, flags 0, urb
df541bc0, burb df541940
Jun 21 01:35:47 mac_hine kernel: usb.c: error getting string descriptor 0 (error=-6)
Jun 21 01:35:47 mac_hine kernel: usb-uhci.c: ENXIO 80000380, flags 0, urb
df541bc0, burb df541940
Jun 21 01:35:47 mac_hine kernel: usb.c: error getting string descriptor 0 (error=-6)
Jun 21 01:35:47 mac_hine kernel: usb-uhci.c: ENXIO 80000380, flags 0, urb
df541bc0, burb df541940
Jun 21 01:35:47 mac_hine kernel: usb.c: error getting string descriptor 0 (error=-6)
Jun 21 01:35:47 mac_hine kernel: usb_control/bulk_msg: timeout
Jun 21 01:35:47 mac_hine kernel: scsi1 : SCSI emulation for USB Mass Storage devices


Version-Release number of selected component (if applicable):
kudzu-0.99.99-1 kernel-2.4.20-18.9

How reproducible:
Always

Steps to Reproduce:
1. Connect Lacie USB drive Before booting
2. Boot using kernels 2.4.20-13.9 / 2.4.20-18.9
3. Allow normal boot..... Kudzu will hang
3a. Interactive boot - and do not run Kudzu - system boots
    Kudzu will hang when run from the command line as will "ls -lR".


    

Expected Results:  On previous kernel releases the system booted with/without
the USB drive attached. This no longer happens.


Additional info:

It took a long while to figure out the reason for Kudzu hanging.
The problem was traced by - 
a. booting off kernel 2.4.20-8 - which worked
b. removing all external and some internal devices and then
   rebooting by attaching one-by-one until the problem occured.

I have not been able to verify the above with other USB devices, but
will try as soon as they become available to me again.

Any system dumps needed, system logs etc. 
ask and you shall receive;)
Comment 1 Bill Nottingham 2003-06-30 11:58:15 EDT
strace of kudzu would be good as a start.

Just kudzu hangs, not the whole system, correct?
Comment 2 caveman_pexy 2003-06-30 18:38:04 EDT
Will run a strace as soon as I get the drive back, 1-2 days.

Partly correct yes.
Only kudzu hangs - the rest of the system is fine as long as
I do not go near the USB drive!

But bear in mind - that the same kudzu works fine with the older kernel
as stated. Only hangs on the 2 latest versions.

But also doing a "ls -lR" the "ls" will hang - not been able
to see exactly where as the spooled output gets lost when
I try and kill or reboot! (seems like somewheres in /proc) but cannot
be sure!
Comment 3 caveman_pexy 2003-07-08 17:31:03 EDT
Sorry I'm only getting back now.
Using another box.

My Linux box got a drop test - about 2 metres
and the motherboard and some other vital internals
got completely wrecked.

Replacement due this week - hopefully - and
will then be able to rebuild and do some more testing,
including the strace.
Comment 4 caveman_pexy 2003-07-23 19:56:14 EDT
Right - 
Eventually got the machine rebuilt with a stock RH9 off of the CD.
- and two bosses glaring over my shoulder for taking this long;) -

Tried to as far as possible to go through the same update sequence
as I remembered doing previously ie. 
Copied the RPMs to the machine in the order received
and updated them in that sequence.

As the kernel where updated, I made sure the USB drive is connected
before the reboot.

With kernel-2.4.20-13.9 I had exactly the same problem of kudzu
hanging during the reboot.
Bypassing kudzu, and the machine rebooted, I discovered much to
my surprise that Mozilla acts up. Exactly the same I think as it did
the previous time as well.
I'm not sure if the two problems are that closely related but.....

As I was sorely running out of time with the bosses, I "forced"
a reinstall of the Mozilla RPMs.

On rebooting the machine, to prove the problem, lo and behold....
kudzu DID NOT hang and the machine booted normally.

Now I am at a loss as to the reason for this.
At least the machine is back in production.

I should be building another machine within the next 10 days.
Allthough not of the same specs, I'll try and recreate the problem
and get the strace etc. done BEFORE anything else.

Can I therefore suggest to change the status to "NEEDINFO" for now
or until someone else picks up a similiar problem.

Regards

/\xx/\  Sleeping Bat
Comment 5 Bill Nottingham 2005-04-19 23:24:46 EDT
Closing bugs on older, no longer supported releases. Apologies for any lack of
response. If this continues on a current release, such as Fedora Core 3, please
opne a new bug - thanks.

Note You need to log in before you can comment on or make changes to this bug.