Bug 982334 - Accepted keys seem to be documented but acceptable values for them are not
Accepted keys seem to be documented but acceptable values for them are not
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: Doc (Show other bugs)
0.7
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 13:55 EDT by Jenny Galipeau
Modified: 2013-07-18 20:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 20:49:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2013-07-08 13:55:40 EDT
Description of problem:
It appears that most of the available KEYs are listed here https://beaker.engineering.redhat.com/keytypes/  However, it seems to be hidden.  I do not believe the list is up to date and there is no where to find out what VALUES are excepted for a KEY.

This really needs to be documented!  

I was given the following from Jeff Burke first ...
"<key_value key="CPUSOCKETS" op="&gt;=" value="4"/>" 
Which did not work ...

Then was given the following from Bill Peck ...
<cpu><sockets op="&gt;" value="4"/></cpu>
Which I am testing out now ...

I just want to make sure I get a machine with at least 4 sockets for subscription-manager testing.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Amit Saha 2013-07-08 20:53:22 EDT
(In reply to Jenny Galipeau from comment #0)
> Description of problem:
> It appears that most of the available KEYs are listed here
> https://beaker.engineering.redhat.com/keytypes/  However, it seems to be
> hidden.  I do not believe the list is up to date and there is no where to
> find out what VALUES are excepted for a KEY.

You can already do a system search using "Key/Value" and in the drop box you will  see a list of all the keys.

However, it is a mighty job (almost futile) to have a list of all possible values that a key can accept. Once the value is specified, we search for it in the database to find whether there is a match - you specify your criteria and we see if there is matching system available.

We can perhaps document this better.



> 
> This really needs to be documented!  
> 
> I was given the following from Jeff Burke first ...
> "<key_value key="CPUSOCKETS" op="&gt;=" value="4"/>" 
> Which did not work ...
> 
> Then was given the following from Bill Peck ...
> <cpu><sockets op="&gt;" value="4"/></cpu>
> Which I am testing out now ...
> 
> I just want to make sure I get a machine with at least 4 sockets for
> subscription-manager testing.
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:
Comment 3 Dan Callaghan 2013-07-10 02:49:17 EDT
(In reply to Amit Saha from comment #2)
> We can perhaps document this better.

We can't document the available keys and their meanings because they are defined by Beaker admins. This is why we have been actively discouraging the use of arbitrary keys in favour of real fields for many years now.

For that reason, the right answer is to use

<cpu><sockets op="&gt;" value="4"/></cpu>

which is described in the RELAX NG schema.
Comment 4 Dan Callaghan 2013-07-18 20:49:30 EDT
Closing as WONTFIX because we are actively working towards eliminating the key-values.

Note You need to log in before you can comment on or make changes to this bug.