Bug 982347 - AttributeError: 'tuple' object has no attribute 'stack'
AttributeError: 'tuple' object has no attribute 'stack'
Status: CLOSED DUPLICATE of bug 982299
Product: Fedora
Classification: Fedora
Component: python-meh (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
abrt_hash:6060864a014e9181d63702fe27e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 14:40 EDT by Steve Tyler
Modified: 2013-08-15 17:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 983789 (view as bug list)
Environment:
Last Closed: 2013-08-15 17:04:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (446.09 KB, text/plain)
2013-07-08 14:40 EDT, Steve Tyler
no flags Details
File: anaconda.log (7.57 KB, text/plain)
2013-07-08 14:40 EDT, Steve Tyler
no flags Details
File: environ (441 bytes, text/plain)
2013-07-08 14:40 EDT, Steve Tyler
no flags Details
File: lsblk_output (1.14 KB, text/plain)
2013-07-08 14:40 EDT, Steve Tyler
no flags Details
File: nmcli_dev_list (3.20 KB, text/plain)
2013-07-08 14:40 EDT, Steve Tyler
no flags Details
File: os_info (179 bytes, text/plain)
2013-07-08 14:40 EDT, Steve Tyler
no flags Details
File: program.log (16.56 KB, text/plain)
2013-07-08 14:40 EDT, Steve Tyler
no flags Details
File: storage.log (30.11 KB, text/plain)
2013-07-08 14:40 EDT, Steve Tyler
no flags Details
File: syslog (73.59 KB, text/plain)
2013-07-08 14:41 EDT, Steve Tyler
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-07-08 14:41 EDT, Steve Tyler
no flags Details
File: packaging.log (174.38 KB, text/plain)
2013-07-08 14:41 EDT, Steve Tyler
no flags Details
anaconda-tb-b7yEgl (Comment 13) (447.24 KB, text/plain)
2013-08-15 08:04 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2013-07-08 14:40:27 EDT
Description of problem:
Attempting to reproduce Bug 982299.

Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 49, in __init__
    if inspect.istraceback(exc_info.stack):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/__init__.py", line 176, in dumpState
    exn = ReverseExceptionDump((None, None, stack), self.mehConfig)
  File "/sbin/anaconda", line 1022, in <lambda>
    signal.signal(signal.SIGUSR2, lambda signum, frame: anaconda.dumpState())
  File "/usr/lib64/python2.7/site-packages/gi/overrides/GLib.py", line 629, in <lambda>
    return (lambda data: callback(*data), user_data)
AttributeError: 'tuple' object has no attribute 'stack'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 Steve Tyler 2013-07-08 14:40:33 EDT
Created attachment 770614 [details]
File: anaconda-tb
Comment 2 Steve Tyler 2013-07-08 14:40:37 EDT
Created attachment 770615 [details]
File: anaconda.log
Comment 3 Steve Tyler 2013-07-08 14:40:40 EDT
Created attachment 770616 [details]
File: environ
Comment 4 Steve Tyler 2013-07-08 14:40:44 EDT
Created attachment 770617 [details]
File: lsblk_output
Comment 5 Steve Tyler 2013-07-08 14:40:47 EDT
Created attachment 770618 [details]
File: nmcli_dev_list
Comment 6 Steve Tyler 2013-07-08 14:40:50 EDT
Created attachment 770619 [details]
File: os_info
Comment 7 Steve Tyler 2013-07-08 14:40:54 EDT
Created attachment 770620 [details]
File: program.log
Comment 8 Steve Tyler 2013-07-08 14:40:57 EDT
Created attachment 770621 [details]
File: storage.log
Comment 9 Steve Tyler 2013-07-08 14:41:00 EDT
Created attachment 770622 [details]
File: syslog
Comment 10 Steve Tyler 2013-07-08 14:41:03 EDT
Created attachment 770623 [details]
File: ifcfg.log
Comment 11 Steve Tyler 2013-07-08 14:41:07 EDT
Created attachment 770624 [details]
File: packaging.log
Comment 12 Steve Tyler 2013-07-08 14:53:52 EDT
Procedure:

$ qemu-img create f19-test-1.img 16G
$ qemu-kvm -m 4096 -hda f19-test-1.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on

Proceed to the Date & Time spoke (for example).
Switch to the installer console (ctrl-alt-f2).
# pkill -USR2 -o anaconda

/tmp/anaconda-tb-* is created.

An exception dialog is displayed after switching back to the installer GUI (ctrl-alt-f7):
AttributeError: 'tuple' object has no attribute 'stack'
Comment 13 Steve Tyler 2013-08-15 07:55:09 EDT
From F19 Live image:
Update to python-meh 0.26-1.
$ liveinst
Go to Installation Summary.
From terminal:
$ sudo pkill -USR2 -o anaconda

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-meh-0.26-1.fc19.noarch, pygobject3-base-3.8.2-2.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         AttributeError: 'tuple' object has no attribute 'stack'
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 14 Steve Tyler 2013-08-15 08:04:13 EDT
Created attachment 786923 [details]
anaconda-tb-b7yEgl (Comment 13)
Comment 15 Steve Tyler 2013-08-15 08:26:44 EDT
When a dump is induced with SIGUSR2, there is no "real" exception, so a traceback seems superfluous.

Changing component to python-meh for analysis.
Comment 16 Steve Tyler 2013-08-15 08:32:22 EDT
(In reply to Steve Tyler from comment #15)
> When a dump is induced with SIGUSR2, there is no "real" exception, so a
> traceback seems superfluous.
> 
> Changing component to python-meh for analysis.

Maybe not. If a thread is hung, we would like to know which one ...
Comment 17 Vratislav Podzimek 2013-08-15 17:04:47 EDT

*** This bug has been marked as a duplicate of bug 982299 ***

Note You need to log in before you can comment on or make changes to this bug.