Bug 982395 - Xephyr hangs when starting
Xephyr hangs when starting
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 18:41 EDT by Florian Sievert
Modified: 2015-02-17 10:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:59:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace output of startup (16.68 KB, text/plain)
2013-07-08 18:41 EDT, Florian Sievert
no flags Details
ldd /bin/Xephyr (1.51 KB, text/plain)
2013-11-07 17:31 EST, Salvatore La Bua
no flags Details

  None (edit)
Description Florian Sievert 2013-07-08 18:41:14 EDT
Created attachment 770699 [details]
Strace output of startup

Description of problem:

When starting Xephyr nothing is happening.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xephyr-1.14.1-4.fc19.x86_64 : A nested server.
Quelle      : fedora
Übereinstimmung von:
Dateiname     : /usr/bin/Xephyr


How reproducible:
Always

Steps to Reproduce:
1. Launch "Xephyr"
2.
3.

Actual results:
Nothing happens

Expected results:
Xepyhr starts and a new window with a nested XServer is started.

Additional info:
 In Fedora 18, I was using the following command line to launch a nested X-Server:
Xephyr :2 -ac -br -screen 1440x900 -reset -terminate

Since Fedora 19 this just hangs. When starting "Xephyr" without any arguments, basically the same happens. Xephyr just not start working and can be exited using "STRG-C" fine. I am attaching an output of strace as it looks like Xephyr is waiting for some kind of lock.
Comment 1 Sergio Monteiro Basto 2013-07-14 09:31:34 EDT
Ĥi,
please check if is the same bug #976995 or bug #984178, 

and let me know if 
Package xorg-x11-server-1.14.2-4.fc19 fix your issue ? ,

you may update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-\*1.14.2-4.fc19'

Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12886/xorg-x11-server-1.14.2-4.fc19
then log in and leave karma (feedback).
Comment 2 Sergio Monteiro Basto 2013-08-01 13:58:19 EDT
you may update it with:

# su -c 'yum update xorg-x11-server-\*' 

you should get :
xorg-x11-server-Xephyr-1.14.2-7.fc19

could you try and report back ?  please.
Comment 3 Gabriel VLASIU 2013-08-10 18:27:09 EDT
Does not start for me either. strace stop on the same line.

xorg-x11-server-Xephyr-1.14.2-9.fc19.x86_64
Comment 4 Florian Sievert 2013-08-14 16:15:29 EDT
Sorry, for being a little bit slow on this. The package does not fix the issue for me here. I am currently using "1.14.2-9.fc19 " and still having the same hang. The issue does also occure on a fresh installation. F18 is working fine.
Comment 5 Sergio Monteiro Basto 2013-08-14 22:31:11 EDT
(In reply to Florian Sievert from comment #4)
> Sorry, for being a little bit slow on this. The package does not fix the
> issue for me here. I am currently using "1.14.2-9.fc19 " and still having
> the same hang. The issue does also occure on a fresh installation. F18 is
> working fine.

Was pity that you have not tested the package xorg-x11-server-Xephyr-1.14.2-7.fc19 , I think at the time the Xephyr worked for me but now also seems that is not working. I have to revert to xorg-x11-server-Xephyr-1.14.2-7.fc19 to check this again ...
Comment 6 Florian Sievert 2013-08-20 15:30:38 EDT
I just reverted the version to the one you gave. Does not fix the issue for me and still hanging.
Comment 7 Branislav Blaškovič 2013-11-02 12:10:39 EDT
Same problem, same strace:
xorg-x11-server-Xephyr-1.14.3-4.fc20.x86_64
Comment 8 Branislav Blaškovič 2013-11-03 05:02:04 EST
Is any workaround available? I need working Xephyr.
Comment 9 Salvatore La Bua 2013-11-05 15:49:44 EST
It reproduces for me also, with xorg-x11-server-Xephyr-1.14.3-2.fc19.x86_64
Comment 10 Eldar Yusupov 2013-11-07 17:19:08 EST
Found this blog post: http://ailin.tucana.uberspace.de/nei/2012/02/xephyr_deadlock_freeze/

$ ldd /bin/Xephyr
	libnvidia-tls.so.325.15 => /usr/lib64/nvidia/tls/libnvidia-tls.so.325.15 (0x00000034ccc00000)
	libnvidia-glcore.so.325.15 => /usr/lib64/nvidia/libnvidia-glcore.so.325.15 (0x00000034c9800000)
	libGL.so.1 => /usr/lib64/nvidia/libGL.so.1 (0x00000034cc800000)

Running Xephyr as
$ LD_LIBRARY_PATH=/usr/lib64 Xephyr -ac -noreset -screen 800x600 :1

Makes it work again.
Comment 11 Salvatore La Bua 2013-11-07 17:31:05 EST
Created attachment 821327 [details]
ldd /bin/Xephyr

Thanks for the reply, I didn't think it could be a nvidia related issue.
Removing the rpmfusion nvidia drivers and installing the official ones (331.20) fixed the issue for me, simply running the plain command.
Comment 12 Florian Sievert 2013-11-27 16:42:06 EST
Hi guys,

good news here. I just randomly tried if it is working again and seems to be fixed by an update recently.
xorg-x11-server-Xephyr-1.14.4-3.fc19.x86_64
xorg-x11-drv-nvidia-libs-331.20-4.fc19.x86_64
Comment 13 Steve 2014-01-18 10:49:02 EST
Just used fedup to upgrade to FC19 and this is happening for me.
I used to run firefox inside of a sandbox, but can't now, since Xephyr just runs and runs and never does anything.
My strace looks similar to the one already posted, i.e. it ends with

statfs64("/sys/fs/selinux", 84, {f_type=0xf97cff8c, f_bsize=4096, f_blocks=0, f_bfree=0, f_bavail=0, f_files=0, f_ffree=0, f_fsid={0, 0}, f_namelen=255, f_frsize=4096, f_flags=4128}) = 0
stat64("/sys/fs/selinux", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
futex(0xb76eb314, FUTEX_WAKE_PRIVATE, 2147483647) = 0

I'm running the 32-bit version of FC19 in Gnome Classic with the nVidia display drivers (304xx, for my old hardware).
Comment 14 Salvatore La Bua 2014-01-18 11:34:13 EST
(In reply to Steve from comment #13)
> I'm running the 32-bit version of FC19 in Gnome Classic with the nVidia
> display drivers (304xx, for my old hardware).

Did you try nvidia drivers 331.20?
Comment 15 Steve 2014-01-18 19:19:59 EST
>Did you try nvidia drivers 331.20?

I can't -- like I said, I'm using the 304xx series of nVidia drivers, since drivers newer than that dropped support for my old hardware.
Comment 16 Salvatore La Bua 2014-01-19 08:18:35 EST
(In reply to Steve from comment #15)

Which version are you using then, and exactly what's your old hardware, geforce 6/7xx?

This is the last updated legacy driver, 304.88
http://www.nvidia.com/object/linux-display-ia32-304.88-driver.html

If that doesn't fix it, not sure what you can do. It is a known nvidia driver issue.
Comment 17 Steve 2014-01-19 11:32:20 EST
But it worked in FC18..the problem only started when I upgraded to FC19 (which I only did because FC18 reached its "end of life").

The last driver that I ran was kmod-nvidia-304xx-3.11.10-100.fc18.i686.PAE-304.116-1.fc18.i686; now I'm running kmod-nvidia-304xx-3.12.7-200.fc19.i686.PAE-304.116-1.fc19.3.i686 .  Unless the ".3" after "fc19" in the name is significant, it should be the same driver.

My hardware is a GeForce 6800 GT (NV40), as reported in Xorg.0.log .

If 304.88 is the last driver that nVidia released in the 304 series, then what is this "304.116" that Fedora is using?

I also tried building FC18's xorg-x11-server under FC19, and using that xorg-x11-server-Xephyr package (I couldn't use the other packages, since they led to too many dependency problems).  No change.  I also tried switching my desktop from GNOME Classic to MATE...no change.  And the last time I checked, the nouveau drivers aren't comprehensive enough to support all my Wine-based video games.
Comment 18 Steve 2014-01-19 13:24:19 EST
Turns out that the latest iteration of the 304xx series drivers is 304.117 .  I rebuilt kmod-nvidia-304xx and xorg-x11-drv-nvidia with that version, and still no luck.

I've reported the bug to nVidia at https://devtalk.nvidia.com/default/topic/548268/ .  At least, I hope that's where I'm supposed to report Linux driver bugs to nVidia.
Comment 19 Fedora End Of Life 2015-01-09 13:46:57 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 20 Fedora End Of Life 2015-02-17 10:59:23 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.