Bug 982426 - symbol lookup error: dwdiff: undefined symbol: u_getIntPropertyValue
symbol lookup error: dwdiff: undefined symbol: u_getIntPropertyValue
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dwdiff (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Hrozek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 22:30 EDT by James Twyford
Modified: 2013-10-09 21:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: dwdiff-2.0.5-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 21:07:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Twyford 2013-07-08 22:30:59 EDT
Description of problem:
Fresh (non-upgraded) F19 install. Regular dwdiff install via yum. The program immediately bails with a signal lookup error. 

Version-Release number of selected component (if applicable):
dwdiff-1.9-6.fc19.x86_64
libicu-50.1.2-5.fc19.x86_64

How reproducible:
Every time

Actual results:
dwdiff: symbol lookup error: dwdiff: undefined symbol: u_getIntPropertyValue

Expected results:
Working output from dwdiff

Additional info:
$ ldd /usr/bin/dwdiff
	linux-vdso.so.1 =>  (0x00007fffab120000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003a76a00000)
	libdl.so.2 => /lib64/libdl.so.2 (0x0000003a76e00000)
	libm.so.6 => /lib64/libm.so.6 (0x0000003a77200000)
	libicui18n.so.50 => /lib64/libicui18n.so.50 (0x0000003aa5200000)
	libicuuc.so.50 => /lib64/libicuuc.so.50 (0x0000003a8a800000)
	libicudata.so.50 => /lib64/libicudata.so.50 (0x0000003a99200000)
	libc.so.6 => /lib64/libc.so.6 (0x0000003a76600000)
	/lib64/ld-linux-x86-64.so.2 (0x0000003a76200000)
	libstdc++.so.6 => /lib64/libstdc++.so.6 (0x0000003a7ba00000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003a78600000)


All linked-against SOs are present on the system.
Comment 1 Jakub Hrozek 2013-07-10 12:33:23 EDT
I'm sorry but I can't reproduce the problem on any of the F-19 machines I run. 

Would simply running ldconfig fix things for you?
Comment 2 James Twyford 2013-07-10 14:57:02 EDT
After running ldconfig, I get a segfault and abrt pops up. It created bug 983229
Comment 3 Jan Kratochvil 2013-08-19 12:38:28 EDT
I have the problem reproducible:
  dwdiff-1.9-6.fc19.x86_64
  libicu-50.1.2-7.fc19.x86_64

It occurs on both my yum-upgraded iron hosts and also on my mock F-19 instance.
ldconfig has not changed anything.
x86_64 and i686 behave indifferently (OS instances in mock).

PASS: dwdiff-2.0.5-1.fc20.x86_64
FAIL: dwdiff-1.9-6.fc19.x86_64
PASS: dwdiff-1.9-5.fc18.x86_64

BTW running just "dwdiff" is not enough:
$ dwdiff
Need two files to compare
$ dwdiff /dev/null /dev/null
dwdiff: symbol lookup error: dwdiff: undefined symbol: u_getIntPropertyValue
Comment 4 Toon Verstraelen 2013-09-28 05:01:51 EDT
Same problem here. I've just downloaded and compiled the upstream dwdiff-2.0.7 sources. These work fine.
Comment 5 Fedora Update System 2013-10-01 15:37:42 EDT
dwdiff-2.0.5-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dwdiff-2.0.5-2.fc19
Comment 6 Fedora Update System 2013-10-02 02:49:04 EDT
Package dwdiff-2.0.5-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dwdiff-2.0.5-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18119/dwdiff-2.0.5-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-10-09 21:07:45 EDT
dwdiff-2.0.5-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.