Bug 982448 - [whql][netkvm]Job 1090-NDISTest 6.0 - [1 Machine] - 1c_Mini6RSSOids failed on win8-64 guest on ovs
[whql][netkvm]Job 1090-NDISTest 6.0 - [1 Machine] - 1c_Mini6RSSOids failed on...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Mike Cao
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 01:31 EDT by Min Deng
Modified: 2014-01-12 07:15 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-12 07:15:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2013-07-09 01:31:59 EDT
Description of problem:
Job 1090-NDISTest 6.0 - [1 Machine] - 1c_Mini6RSSOids failed on win8-64 guest on ovs

Version-Release number of selected component (if applicable):
build 65

How reproducible:
6 times 
Steps to Reproduce:
1.boot up guest 
  /usr/libexec/qemu-kvm -m 6G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic,+sep -usb -device usb-tablet -drive file=win8-64-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/ovs0-ifup,downscript=/etc/ovs0-ifdown -device virtio-net-pci,netdev=hostnet0,mac=00:31:51:33:11:32,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,sndbuf=0,id=hostnet2,script=/etc/ovs1-ifup,downscript=/etc/ovs1-ifdown -device e1000,netdev=hostnet2,mac=00:22:62:1a:12:20,bus=pci.0,addr=0x6 -uuid 795ff04b-3cb4-4aad-bdfe-a35df3e8c27d -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-64-65-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -vga cirrus -name win8-64-nic1-64-HCK-new -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=0 -monitor stdio

2.submit the job to hck
3.

Actual results:
The job always failed because of these errors,tried it via *smp = 8,cores = 8 *.
--------------------------------------------------------------------------------
 Result 
 Failed 
 Start Test 7/9/2013 12:24:24.173 AM 1c_mini6rssoids 
Message 7/9/2013 12:24:24.173 AM This script test the various receive side scaling oids. The miniport should:

1. Return a valid CAPABILITIES structure which includes support for
   NdisHashFunctionToeplitz
2. Accept all the PARAMETER sets if the hash information is valid & supported
3. Reject the PARAMETER sets if the hash information is not supported or invalid
   or if the indirection table or the structure itself is not of the correct size.
4. In case the miniport rejects a PARAMETER set, it should retain the previously
   set PARAMETERs structure
5. Miniport should handle 64 bit misaligned requests correctly.


 
End Test 7/9/2013 12:25:10.173 AM 1c_mini6rssoids 
Result:   Fail 
 
 Failed 
 Start Test 7/9/2013 12:24:40.173 AM Verifying Standardized Keyword *NumRssQueue 
Error 7/9/2013 12:24:40.173 AM Not Enough RSS Capable CPUs (4) to support the initial value of *NumRssQueues (8). 
File:    Line: 0 
Error Type:   NT_STATUS 
Error Code:   0x15b38 
Error Text:   Error 0x00015b38 
End Test 7/9/2013 12:24:40.173 AM Verifying Standardized Keyword *NumRssQueue 
Result:   Fail 
Repro:   1c_mini6rssoids 
 

Expected results:
The job can pass

Additional info:
The job isn't reproduced on bridge configration.
Comment 2 Dmitry Fleytman 2013-10-01 08:22:22 EDT
The problem is here:

7/9/2013 12:24:40.173 AM Verifying Standardized Keyword *NumRssQueue Error
7/9/2013 12:24:40.173 AM Not Enough RSS Capable CPUs (4) to support the initial value of *NumRssQueues (8).

This test requires guest with at least 8 VCPUs.
Comment 3 Miki Mishael 2014-01-12 07:15:52 EST
Hi,

I have made the test, and it passed successfully twice with 8 cores,
with "-m 4G -smp 8,cores=8".

I'm closing the bug, It can't be reproduced. 

Thanks.

Note You need to log in before you can comment on or make changes to this bug.