Bug 98247 - Installer makes many mistakes in dependency resolution
Installer makes many mistakes in dependency resolution
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-28 20:52 EDT by Steve Snyder
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-02 12:52:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2003-06-28 20:52:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030530

Description of problem:
Immediately after the initial boot, I ran "rpm -Va".  It reported many, many
unsatisfied dependencies.

Some background: My goal in installing RHL v9 was to have all of the non-GUI
packages and none of the GUI packages installed.  To this end I selected
Everything in the package selection screen, then manually deselected all the
XFree86, Gnome and KDE packages I could find.  I then let the installer  work
out the dependency conflicts and indicated I did not want to install the
packages with missing dependencies.  Installation continued as usual from there.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install Everything, excepting GUI apps, as described above
2. Immediately after the initial boot, run "rpm -Va".
    

Actual Results:  # rpm -Va | grep Unsatis
Unsatisfied dependencies for redhat-config-nfs-1.0.4-5: pygtk2
Unsatisfied dependencies for redhat-config-users-1.1.5-7: pygtk2, pygtk2-libglade
Unsatisfied dependencies for gimp-print-utils-4.2.4-5: gimp-print = 4.2.4
Unsatisfied dependencies for SDL_net-devel-1.2.4-5: SDL_net = 1.2.4-5
Unsatisfied dependencies for libglade2-devel-2.0.1-3: gtk2-devel >= 2.1.2,
libglade2 = 2.0.1
Unsatisfied dependencies for pygtk2-devel-1.99.14-4: pygtk2 = 1.99.14
Unsatisfied dependencies for libmrproject-devel-0.9-5: gtk+-devel, libmrproject
= 0.9
Unsatisfied dependencies for redhat-config-kickstart-2.3.6-4: pygtk2 >= 1.99.11,
pygtk2-libglade
Unsatisfied dependencies for gnome-python2-gconf-1.99.14-5: GConf2 >= 1.1.10,
libgconf-2.so.4
Unsatisfied dependencies for libao-devel-0.8.3-3: libao = 0.8.3
Unsatisfied dependencies for redhat-switch-mail-gnome-0.5.17-1: libglade2,
pygtk2, pygtk2-libglade
Unsatisfied dependencies for redhat-config-securitylevel-1.1.1-3: pygtk2
Unsatisfied dependencies for redhat-config-language-1.0.4-1: pygtk2
Unsatisfied dependencies for librsvg-devel-1.0.2-8: librsvg = 1.0.2
Unsatisfied dependencies for GConf2-devel-2.2.0-1: GConf2 = 2.2.0
Unsatisfied dependencies for gail-devel-1.2.0-1: gail = 1.2.0, gtk2-devel >= 2.2.0
Unsatisfied dependencies for gimp-print-devel-4.2.4-5: gimp-print = 4.2.4
Unsatisfied dependencies for authconfig-gtk-4.3.4-1: pygtk2-libglade
Unsatisfied dependencies for redhat-config-rootpassword-1.0.2-4: pygtk2
Unsatisfied dependencies for redhat-config-soundcard-1.0.4-2: pygtk2
Unsatisfied dependencies for SDL_mixer-devel-1.2.4-7: SDL_mixer = 1.2.4
Unsatisfied dependencies for librsvg2-devel-2.2.3-1: gtk2-devel >= 2.2.0,
librsvg2 = 2.2.3
Unsatisfied dependencies for gimp-print-cups-4.2.4-5: libgimpprint.so.1
Unsatisfied dependencies for libgnomeprintui22-devel-2.2.1.1-1: gtk2-devel >=
2.2.0, libgnomeprint22-devel >= 2.2.1.1, libgnomeprintui22 = 2.2.1.1
Unsatisfied dependencies for libwnck-devel-2.2.1-2: gtk2-devel >= 2.2.0, libwnck
= 2.2.1, pango-devel >= 1.2.0
Unsatisfied dependencies for redhat-switch-printer-gnome-0.5.16-1: libglade2,
pygtk2, pygtk2-libglade
Unsatisfied dependencies for libgnomeprintui-devel-1.116.0-4: gtk2-devel >=
2.0.2, libgnomeprint-devel >= 1.116.0, libgnomeprintui = 1.116.0
Unsatisfied dependencies for vorbis-tools-1.0-3: libao >= 0.8.3, libao.so.2
Unsatisfied dependencies for redhat-config-samba-1.0.4-1: pygtk2
Unsatisfied dependencies for redhat-logviewer-0.8.5-1: pygtk2
Unsatisfied dependencies for SDL_image-devel-1.2.2-5: SDL-devel >= 1.2.3-5,
SDL_image = 1.2.2
Unsatisfied dependencies for libgnomecanvas-devel-2.2.0.1-1: gtk2-devel >=
2.1.2, libgnomecanvas = 2.2.0.1
Unsatisfied dependencies for pydict-0.3.0-4: pygtk2



Expected Results:  The installer should not install packages with unsatisfied
dependencies unless the user explicit requests it.

Additional info:

The installer was partially correct in removing packages with missing
dependencies.  For example, the Mozilla packages were not installed even though
I did not state an installation preference for those specfic packages. 
Nevertheless, I stated that I did *not* want packages with missing dependencies
installed, yet here they are.
Comment 1 Jeremy Katz 2003-07-02 12:52:29 EDT
This isn't a problem any more in the current code.

Note You need to log in before you can comment on or make changes to this bug.