This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 982479 - volume status command not providing host names for NFS and SHD
volume status command not providing host names for NFS and SHD
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Kaushal
Vijaykumar Koppad
:
: 954276 (view as bug list)
Depends On: 927648
Blocks: 954276 965825 966738
  Show dependency treegraph
 
Reported: 2013-07-09 03:04 EDT by Kaushal
Modified: 2014-08-24 20:50 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta4_1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 927648
Environment:
Last Closed: 2013-09-23 18:24:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushal 2013-07-09 03:04:15 EDT
+++ This bug was initially created as a clone of Bug #927648 +++

Description of problem:

'gluster volume status <vol>' command doesn't display host name for NFS and SHD services, instead it displays the UUID of the peers.

Version-Release number of selected component (if applicable):

glusterfs 3.4.0alpha2 built on Mar  6 2013 23:54:05

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

[root@localhost ~]# gluster volume status r1
Status of volume: r1
Gluster process                                         Port    Online  Pid
------------------------------------------------------------------------------
Brick 10.70.37.211:/tmp/r1a                             49163   Y       28822
Brick 10.70.37.216:/tmp/r1b                             49156   Y       9345
NFS Server on localhost                                 38467   Y       28834
Self-heal Daemon on localhost                           N/A     Y       28846
NFS Server on 24b83353-b2d7-4563-b4ea-7ebfacfcf3bb      38467   Y       9487
Self-heal Daemon on 24b83353-b2d7-4563-b4ea-7ebfacfcf3b
b                                                       N/A     Y       9499
NFS Server on 19f601e2-e9be-41a0-8b1c-0f4334cf3e44      38467   Y       9358
Self-heal Daemon on 19f601e2-e9be-41a0-8b1c-0f4334cf3e4
4                                                       N/A     Y       9371
 
There are no active volume tasks


Expected results:


Additional info:

--- Additional comment from Kanagaraj on 2013-03-26 17:18:58 IST ---

[root@localhost ~]# gluster volume status r1 --xml
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
  <opRet>0</opRet>
  <opErrno>115</opErrno>
  <opErrstr/>
  <volStatus>
    <volumes>
      <volume>
        <volName>r1</volName>
        <nodeCount>8</nodeCount>
        <node>
          <hostname>10.70.37.211</hostname>
          <path>/tmp/r1a</path>
          <status>1</status>
          <port>49163</port>
          <pid>28822</pid>
        </node>
        <node>
          <hostname>10.70.37.216</hostname>
          <path>/tmp/r1b</path>
          <status>1</status>
          <port>49156</port>
          <pid>9345</pid>
        </node>
        <node>
          <hostname>NFS Server</hostname>
          <path>localhost</path>
          <status>1</status>
          <port>38467</port>
          <pid>28834</pid>
        </node>
        <node>
          <hostname>Self-heal Daemon</hostname>
          <path>localhost</path>
          <status>1</status>
          <port>N/A</port>
          <pid>28846</pid>
        </node>
        <node>
          <hostname>NFS Server</hostname>
          <path>24b83353-b2d7-4563-b4ea-7ebfacfcf3bb</path>
          <status>1</status>
          <port>38467</port>
          <pid>9487</pid>
        </node>

        ......

        <tasks/>
      </volume>
    </volumes>
  </volStatus>
</cliOutput>


Previously the <path> used to display host name instead of UUID.

--- Additional comment from Kaushal on 2013-04-08 10:46:02 IST ---

Do you still have the glusterd logs for the peer where this command was issued? If you do, can you attach them.

--- Additional comment from Kanagaraj on 2013-04-08 11:02:38 IST ---

Attached the log files from peers.

--- Additional comment from Anand Avati on 2013-04-23 12:18:04 IST ---

REVIEW: http://review.gluster.org/4873 (glusterd: Fix uuid to hostname conversion for 'volume status') posted (#1) for review on master by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-04-23 12:23:53 IST ---

REVIEW: http://review.gluster.org/4874 (glusterd: Fix uuid to hostname conversion for 'volume status') posted (#1) for review on release-3.4 by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-04-23 12:41:01 IST ---

REVIEW: http://review.gluster.org/4873 (glusterd: Fix uuid to hostname conversion for 'volume status') posted (#2) for review on master by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-04-23 12:42:27 IST ---

REVIEW: http://review.gluster.org/4874 (glusterd: Fix uuid to hostname conversion for 'volume status') posted (#2) for review on release-3.4 by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-05-13 12:09:19 IST ---

COMMIT: http://review.gluster.org/4873 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit fd36cabb0db4139cba97fc75c6169b57ebea3e9d
Author: Kaushal M <kaushal@redhat.com>
Date:   Tue Apr 23 12:11:00 2013 +0530

    glusterd: Fix uuid to hostname conversion for 'volume status'
    
    Change-Id: I46c41c29c2d11652f6d8ccd5637be0ac9774fc1d
    BUG: 927648
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/4873
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

--- Additional comment from Anand Avati on 2013-05-14 16:43:59 IST ---

COMMIT: http://review.gluster.org/4874 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit e6b4c04709a14bff0379ccfc414b8feec35f78fa
Author: Kaushal M <kaushal@redhat.com>
Date:   Tue Apr 23 12:11:00 2013 +0530

    glusterd: Fix uuid to hostname conversion for 'volume status'
    
    BUG: 927648
    Change-Id: Ic016e9d1f090372329a8a2e530dac5fc6ed6c5ae
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/4874
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 2 Kaushal 2013-07-10 05:05:39 EDT
*** Bug 954276 has been marked as a duplicate of this bug. ***
Comment 3 Vijaykumar Koppad 2013-07-22 09:54:49 EDT
verified on 3.4.0.12rhs.beta5-2.el6rhs.x86_64.
Comment 4 Scott Haines 2013-09-23 18:24:55 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.